summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-21 04:42:11 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-21 04:42:11 +0000
commitc13b5d42d65f9891f628bab1f5d0c91b39596205 (patch)
tree7e216adc82fdd43998c611b6d9dcf9d0f41a172b /sys-apps/rlocate
parentold (diff)
downloadgentoo-2-c13b5d42d65f9891f628bab1f5d0c91b39596205.tar.gz
gentoo-2-c13b5d42d65f9891f628bab1f5d0c91b39596205.tar.bz2
gentoo-2-c13b5d42d65f9891f628bab1f5d0c91b39596205.zip
Version bump.
(Portage version: 2.1.2_rc3-r8)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog7
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.43
-rw-r--r--sys-apps/rlocate/rlocate-0.5.4.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 73fc8461a2aa..32f0731941a9 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.20 2006/10/07 05:14:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.21 2006/12/21 04:42:10 vapier Exp $
+
+*rlocate-0.5.4 (21 Dec 2006)
+
+ 21 Dec 2006; Mike Frysinger <vapier@gentoo.org> +rlocate-0.5.4.ebuild:
+ Version bump.
07 Oct 2006; Jeroen Roovers <jer@gentoo.org> rlocate-0.5.3.ebuild:
Marked ~hppa.
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.4 b/sys-apps/rlocate/files/digest-rlocate-0.5.4
new file mode 100644
index 000000000000..076597601e1d
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.4
@@ -0,0 +1,3 @@
+MD5 dd333d8ab2400cb4f0891ca73771d35c rlocate-0.5.4.tar.gz 182141
+RMD160 a189ac29e2c27e0eee6984eb7d03bd21bdb9eaf5 rlocate-0.5.4.tar.gz 182141
+SHA256 5c07a5b7df1f96f3018052cf378ce754d393119e729a5ae3cc5ff933213008f3 rlocate-0.5.4.tar.gz 182141
diff --git a/sys-apps/rlocate/rlocate-0.5.4.ebuild b/sys-apps/rlocate/rlocate-0.5.4.ebuild
new file mode 100644
index 000000000000..ffdf5c886560
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.4.ebuild,v 1.1 2006/12/21 04:42:10 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.3-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}