summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-01-29 14:07:44 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-01-29 14:07:44 +0000
commitf0bc5fe0c8bafde7d3d29b0727e423aa00d07713 (patch)
tree58beb0d99b1972368733105e87f3e16abb63ff89 /sys-apps/qingy
parentFix metadata.xml (diff)
downloadgentoo-2-f0bc5fe0c8bafde7d3d29b0727e423aa00d07713.tar.gz
gentoo-2-f0bc5fe0c8bafde7d3d29b0727e423aa00d07713.tar.bz2
gentoo-2-f0bc5fe0c8bafde7d3d29b0727e423aa00d07713.zip
qingy-0.9.6-r1.ebuild, qingy-0.9.6-r3.ebuild, qingy-0.9.7.ebuild:
Added more USE flags checks for DirectFB. Closes bug #256424. qingy-0.9.7.ebuild: Stable for x86. See bug #253101. (Portage version: 2.1.6.4/cvs/Linux 2.6.24-tuxonice-r9 i686)
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/ChangeLog8
-rw-r--r--sys-apps/qingy/qingy-0.9.6-r1.ebuild27
-rw-r--r--sys-apps/qingy/qingy-0.9.6-r3.ebuild27
-rw-r--r--sys-apps/qingy/qingy-0.9.7.ebuild29
4 files changed, 50 insertions, 41 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 8bb7421baacd..565c19dd2d78 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.53 2008/08/23 06:20:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.54 2009/01/29 14:07:44 s4t4n Exp $
+
+ 29 Jan 2009; Michele Noberasco <s4t4n@gentoo.org>
+ qingy-0.9.6-r1.ebuild, qingy-0.9.6-r3.ebuild, qingy-0.9.7.ebuild:
+ Added more USE flags checks for DirectFB. Closes bug #256424.
+ qingy-0.9.7.ebuild:
+ Stable for x86. See bug #253101.
23 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/sys-apps/qingy/qingy-0.9.6-r1.ebuild b/sys-apps/qingy/qingy-0.9.6-r1.ebuild
index 9dc8c831b424..f47ba8a3f652 100644
--- a/sys-apps/qingy/qingy-0.9.6-r1.ebuild
+++ b/sys-apps/qingy/qingy-0.9.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r1.ebuild,v 1.3 2007/11/22 17:07:35 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r1.ebuild,v 1.4 2009/01/29 14:07:44 s4t4n Exp $
inherit elisp-common eutils
@@ -43,17 +43,6 @@ src_unpack()
if use directfb; then
- #Issues with this version have been work-arounded :-)
- #if has_version "=dev-libs/DirectFB-0.9.25.1"; then
- # echo
- # ewarn "You are running DirectFB version 0.9.25.1:"
- # ewarn "I advise against that as this version introduces"
- # ewarn "instability, expecially when closing DirectFB mode!"
- # ewarn "Please consider downgrading DirectFB to version 0.9.24..."
- # echo
- # epause
- #fi
-
if ! built_with_use -a dev-libs/DirectFB fbcon jpeg png truetype; then
echo
eerror "qingy expects DirectFB to provide certain capabilities."
@@ -64,6 +53,18 @@ src_unpack()
die "USE flags check failed"
fi
+ if has_version ">=dev-libs/DirectFB-1.2.6"; then
+ if built_with_use -a dev-libs/DirectFB X; then
+ echo
+ eerror "Detected DirectFB version >= 1.2.6."
+ eerror "For this version of DirectFB to work with qingy"
+ eerror "X USE flag must be disabled."
+ eerror "You must rebuild DirectFB with X USE flag disabled!"
+ echo
+ die "USE flags check failed"
+ fi
+ fi
+
fi
unpack ${A}
diff --git a/sys-apps/qingy/qingy-0.9.6-r3.ebuild b/sys-apps/qingy/qingy-0.9.6-r3.ebuild
index d6b689c88c77..45615ceabbd8 100644
--- a/sys-apps/qingy/qingy-0.9.6-r3.ebuild
+++ b/sys-apps/qingy/qingy-0.9.6-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r3.ebuild,v 1.3 2008/04/12 17:34:27 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.6-r3.ebuild,v 1.4 2009/01/29 14:07:44 s4t4n Exp $
inherit elisp-common eutils pam
@@ -46,17 +46,6 @@ src_unpack()
if use directfb; then
- #Issues with this version have been work-arounded :-)
- #if has_version "=dev-libs/DirectFB-0.9.25.1"; then
- # echo
- # ewarn "You are running DirectFB version 0.9.25.1:"
- # ewarn "I advise against that as this version introduces"
- # ewarn "instability, expecially when closing DirectFB mode!"
- # ewarn "Please consider downgrading DirectFB to version 0.9.24..."
- # echo
- # epause
- #fi
-
if ! built_with_use -a dev-libs/DirectFB fbcon jpeg png truetype; then
echo
eerror "qingy expects DirectFB to provide certain capabilities."
@@ -67,6 +56,18 @@ src_unpack()
die "USE flags check failed"
fi
+ if has_version ">=dev-libs/DirectFB-1.2.6"; then
+ if built_with_use -a dev-libs/DirectFB X; then
+ echo
+ eerror "Detected DirectFB version >= 1.2.6."
+ eerror "For this version of DirectFB to work with qingy"
+ eerror "X USE flag must be disabled."
+ eerror "You must rebuild DirectFB with X USE flag disabled!"
+ echo
+ die "USE flags check failed"
+ fi
+ fi
+
fi
unpack ${A}
diff --git a/sys-apps/qingy/qingy-0.9.7.ebuild b/sys-apps/qingy/qingy-0.9.7.ebuild
index 7820eb27d284..c7ba258250f1 100644
--- a/sys-apps/qingy/qingy-0.9.7.ebuild
+++ b/sys-apps/qingy/qingy-0.9.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.7.ebuild,v 1.1 2008/07/08 15:51:02 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.7.ebuild,v 1.2 2009/01/29 14:07:44 s4t4n Exp $
inherit elisp-common eutils pam
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE="crypt directfb emacs gpm logrotate opensslcrypt pam static X"
RDEPEND=">=sys-libs/ncurses-5.4-r6
@@ -46,17 +46,6 @@ src_unpack()
if use directfb; then
- #Issues with this version have been work-arounded :-)
- #if has_version "=dev-libs/DirectFB-0.9.25.1"; then
- # echo
- # ewarn "You are running DirectFB version 0.9.25.1:"
- # ewarn "I advise against that as this version introduces"
- # ewarn "instability, expecially when closing DirectFB mode!"
- # ewarn "Please consider downgrading DirectFB to version 0.9.24..."
- # echo
- # epause
- #fi
-
if ! built_with_use -a dev-libs/DirectFB fbcon jpeg png truetype; then
echo
eerror "qingy expects DirectFB to provide certain capabilities."
@@ -67,6 +56,18 @@ src_unpack()
die "USE flags check failed"
fi
+ if has_version ">=dev-libs/DirectFB-1.2.6"; then
+ if built_with_use -a dev-libs/DirectFB X; then
+ echo
+ eerror "Detected DirectFB version >= 1.2.6."
+ eerror "For this version of DirectFB to work with qingy"
+ eerror "X USE flag must be disabled."
+ eerror "You must rebuild DirectFB with X USE flag disabled!"
+ echo
+ die "USE flags check failed"
+ fi
+ fi
+
fi
unpack ${A}