summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-13 00:52:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-13 00:52:06 +0000
commit1f902a610af5057b677945433c0a57bd13114e0c (patch)
tree513186dc943df140cc340142f316d01f32e45c82 /sys-apps/pv
parentRevision bump to make sure that hte package is built with large file support ... (diff)
downloadgentoo-2-1f902a610af5057b677945433c0a57bd13114e0c.tar.gz
gentoo-2-1f902a610af5057b677945433c0a57bd13114e0c.tar.bz2
gentoo-2-1f902a610af5057b677945433c0a57bd13114e0c.zip
QA: update to EAPI 2, drop debug USE flag as it only changes CFLAGS, die on dodoc failure, use proper CC/LD so that cross-compile works. See bug #345933.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/ChangeLog8
-rw-r--r--sys-apps/pv/pv-1.1.4-r1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index 1ef2534125c3..4947d45f0111 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pv
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.12 2010/03/31 18:29:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.13 2010/12/13 00:52:06 flameeyes Exp $
+
+*pv-1.1.4-r1 (13 Dec 2010)
+
+ 13 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> +pv-1.1.4-r1.ebuild:
+ QA: update to EAPI 2, drop debug USE flag as it only changes CFLAGS, die on
+ dodoc failure, use proper CC/LD so that cross-compile works. See bug #345933.
31 Mar 2010; Raúl Porcel <armin76@gentoo.org> pv-1.1.4.ebuild:
Add ~arm
diff --git a/sys-apps/pv/pv-1.1.4-r1.ebuild b/sys-apps/pv/pv-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..69007ffaf911
--- /dev/null
+++ b/sys-apps/pv/pv-1.1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.1.4-r1.ebuild,v 1.1 2010/12/13 00:52:06 flameeyes Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="mirror://sourceforge/pipeviewer/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="nls"
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README doc/NEWS doc/TODO || die
+}