summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-02-05 11:25:10 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-02-05 11:25:10 +0000
commitc09df9bfb2f4c17b6e8a246dceb9935a208276f9 (patch)
tree4472f8cbbe354ab6f1a70bff20d3360366e31628 /sys-apps/policycoreutils
parentEAPI3 and prefix fixes, bug #315805, also clean up pax-stuff, bug #353587, re... (diff)
downloadgentoo-2-c09df9bfb2f4c17b6e8a246dceb9935a208276f9.tar.gz
gentoo-2-c09df9bfb2f4c17b6e8a246dceb9935a208276f9.tar.bz2
gentoo-2-c09df9bfb2f4c17b6e8a246dceb9935a208276f9.zip
New upstream release.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/ChangeLog8
-rw-r--r--sys-apps/policycoreutils/policycoreutils-2.0.82.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index f546a1630e64..3c2138811b69 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.78 2011/02/05 11:23:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.79 2011/02/05 11:25:10 blueness Exp $
+
+*policycoreutils-2.0.82 (05 Feb 2011)
+
+ 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
+ +policycoreutils-2.0.82.ebuild:
+ New upstream release.
*policycoreutils-2.0.69-r2 (05 Feb 2011)
diff --git a/sys-apps/policycoreutils/policycoreutils-2.0.82.ebuild b/sys-apps/policycoreutils/policycoreutils-2.0.82.ebuild
new file mode 100644
index 000000000000..9c69bae00529
--- /dev/null
+++ b/sys-apps/policycoreutils/policycoreutils-2.0.82.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-2.0.82.ebuild,v 1.1 2011/02/05 11:25:10 blueness Exp $
+
+IUSE="nls"
+
+inherit eutils python
+
+EXTRAS_VER="1.20"
+SEMNG_VER="2.0.45"
+SELNX_VER="2.0.94"
+SEPOL_VER="2.0.41"
+
+#BUGFIX_PATCH="${FILESDIR}/policycoreutils-2.0.62-po.diff"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20100525/devel/${P}.tar.gz
+ mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPS=">=sys-libs/libselinux-${SELNX_VER}
+ >=sys-libs/glibc-2.4
+ >=sys-process/audit-1.5.1
+ >=sys-libs/libcap-1.10-r10
+ sys-libs/pam
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-libs/libcap-ng
+ >=sys-libs/libsepol-${SEPOL_VER}"
+
+# pax-utils for scanelf used by rlpkg
+RDEPEND="${COMMON_DEPS}
+ dev-python/sepolgen
+ app-misc/pax-utils"
+
+DEPEND="${COMMON_DEPS}
+ nls? ( sys-devel/gettext )"
+
+S2=${WORKDIR}/policycoreutils-extra
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # rlpkg is more useful than fixfiles
+ sed -i -e '/^all/s/fixfiles//' "${S}/scripts/Makefile" \
+ || die "fixfiles sed 1 failed"
+ sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
+ || die "fixfiles sed 2 failed"
+ # removing sandbox for the time being, need to
+ # rename in future to sesandbox?
+ sed -i -e 's/sandbox //' "${S}/Makefile" \
+ || die "failed removing sandbox"
+}
+
+src_compile() {
+ einfo "Compiling policycoreutils"
+ emake -C "${S}" PYLIBVER="python$(python_get_version)" AUDIT_LOG_PRIV=y || die
+ einfo "Compiling policycoreutils-extra"
+ emake -C "${S2}" || die
+}
+
+src_install() {
+ python_need_rebuild
+
+ einfo "Installing policycoreutils"
+ make DESTDIR="${D}" -C "${S}" PYLIBVER="python$(python_get_version)" AUDIT_LOG_PRIV=y install || die
+ einfo "Installing policycoreutils-extra"
+ make DESTDIR="${D}" -C "${S2}" install || die
+
+ # remove redhat-style init script
+ rm -fR "${D}/etc/rc.d"
+
+ # compatibility symlinks
+ dosym /sbin/setfiles /usr/sbin/setfiles
+ dosym /lib/rc/runscript_selinux.so /lib/rcscripts/runscript_selinux.so
+
+ if has_version '<sys-libs/pam-0.99'; then
+ # install compat pam.d entries
+ # for older pam
+ make DESTDIR="${D}" -C "${S2}/pam.d" install || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)
+}