summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-01-29 15:19:00 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-01-29 15:19:00 +0000
commit7f04eaf6694aea87882e3cdeb928de823da51545 (patch)
tree9d7d668507df8a39144d8a7778c26fee9acca495 /sys-apps/policycoreutils
parentalpha/ia64/sparc stable wrt #207634 (diff)
downloadgentoo-2-7f04eaf6694aea87882e3cdeb928de823da51545.tar.gz
gentoo-2-7f04eaf6694aea87882e3cdeb928de823da51545.tar.bz2
gentoo-2-7f04eaf6694aea87882e3cdeb928de823da51545.zip
sys-apps/policycoreutils: new upstream bugfix release.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/ChangeLog10
-rw-r--r--sys-apps/policycoreutils/files/digest-policycoreutils-1.34.156
-rw-r--r--sys-apps/policycoreutils/policycoreutils-1.34.15.ebuild103
3 files changed, 117 insertions, 2 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index caa563f8ce37..0993c52adfc3 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/policycoreutils
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.66 2007/10/19 14:57:32 pebenito Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.67 2008/01/29 15:19:00 pebenito Exp $
+
+*policycoreutils-1.34.15 (29 Jan 2008)
+
+ 29 Jan 2008; Chris PeBenito <pebenito@gentoo.org>
+ +policycoreutils-1.34.15.ebuild:
+ New upstream bugfix release.
19 Oct 2007; Chris PeBenito <pebenito@gentoo.org>
policycoreutils-1.34.11.ebuild:
diff --git a/sys-apps/policycoreutils/files/digest-policycoreutils-1.34.15 b/sys-apps/policycoreutils/files/digest-policycoreutils-1.34.15
new file mode 100644
index 000000000000..1b77383bc2d3
--- /dev/null
+++ b/sys-apps/policycoreutils/files/digest-policycoreutils-1.34.15
@@ -0,0 +1,6 @@
+MD5 15f7d63970ba39899279cb2c37632a48 policycoreutils-1.34.15.tgz 317142
+RMD160 5ba97a754773a31740521d00fd84779c47f6f29a policycoreutils-1.34.15.tgz 317142
+SHA256 bdeda76caeb7ea2b8950b47991c85c9429d092e19f8be06d62366780548a3606 policycoreutils-1.34.15.tgz 317142
+MD5 b7c70b77c36476b5dd1d2c2e7308f607 policycoreutils-extra-1.18.tar.bz2 17109
+RMD160 150a443b3942808ab3ef2a1fec8da789776861f5 policycoreutils-extra-1.18.tar.bz2 17109
+SHA256 0835baaef5ad93e130cf399048752f0821a545cf33ce53760ae46d43c043e8eb policycoreutils-extra-1.18.tar.bz2 17109
diff --git a/sys-apps/policycoreutils/policycoreutils-1.34.15.ebuild b/sys-apps/policycoreutils/policycoreutils-1.34.15.ebuild
new file mode 100644
index 000000000000..9655bf058f07
--- /dev/null
+++ b/sys-apps/policycoreutils/policycoreutils-1.34.15.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.34.15.ebuild,v 1.1 2008/01/29 15:19:00 pebenito Exp $
+
+IUSE="nls"
+
+inherit eutils python
+
+EXTRAS_VER="1.18"
+SEMNG_VER="1.10"
+SELNX_VER="1.34"
+
+# BUGFIX_PATCH="${FILESDIR}/policycoreutils-1.30.6.diff"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz
+ mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND=">=sys-libs/libselinux-${SELNX_VER}
+ >=sys-libs/glibc-2.4
+ >=sys-process/audit-1.5.1
+ >=sys-libs/libcap-1.10-r10
+ sys-libs/pam
+ =sys-libs/libsemanage-${SEMNG_VER}*"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S2=${WORKDIR}/policycoreutils-extra
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+ # rlpkg is more useful than fixfiles
+ sed -i -e '/^all/s/fixfiles//' ${S}/scripts/Makefile \
+ || die "fixfiles sed 1 failed"
+ sed -i -e '/fixfiles/d' ${S}/scripts/Makefile \
+ || die "fixfiles sed 2 failed"
+
+ local SUBDIRS="`cd ${S} && find -type d | cut -d/ -f2`"
+
+ if ! useq nls; then
+ for i in ${SUBDIRS}; do
+ # disable locale stuff
+ sed -i -e s/-DUSE_NLS// ${S}/${i}/Makefile \
+ || die "${i} NLS sed failed"
+ done
+ fi
+
+ # Gentoo Fixes
+ for i in ${SUBDIRS}; do
+ # add in CFLAGS
+ sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" ${S}/${i}/Makefile \
+ || die "${i} Makefile CFLAGS fix failed."
+ done
+}
+
+src_compile() {
+ python_version
+
+ einfo "Compiling policycoreutils"
+ emake -C ${S} PYLIBVER="python${PYVER}" AUDIT_LOG_PRIV=y || die
+ einfo "Compiling policycoreutils-extra"
+ emake -C ${S2} || die
+}
+
+src_install() {
+ python_version
+
+ einfo "Installing policycoreutils"
+ make DESTDIR="${D}" -C ${S} PYLIBVER="python${PYVER}" AUDIT_LOG_PRIV=y install || die
+ einfo "Installing policycoreutils-extra"
+ make DESTDIR="${D}" -C ${S2} install || die
+
+ # remove redhat-style init script
+ rm -fR ${D}/etc/rc.d
+
+ # compatibility symlink
+ dosym /sbin/setfiles /usr/sbin/setfiles
+
+ if has_version '<sys-libs/pam-0.99'; then
+ # install compat pam.d entries
+ # for older pam
+ make DESTDIR="${D}" -C ${S2}/pam.d install || die
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}usr/lib/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup ${ROOT}usr/lib/python${PYVER}/site-packages
+}