summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-09-06 08:48:53 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-09-06 08:48:53 +0000
commit32625b8d4b473d9f7c99db316fdc2387d4c6c70d (patch)
treef7bfc10b14bb34943bdbef3fa99dc4772b2db644 /sys-apps/pmount
parentClaiming ownership. (diff)
downloadgentoo-2-32625b8d4b473d9f7c99db316fdc2387d4c6c70d.tar.gz
gentoo-2-32625b8d4b473d9f7c99db316fdc2387d4c6c70d.tar.bz2
gentoo-2-32625b8d4b473d9f7c99db316fdc2387d4c6c70d.zip
Version bump, bug #191129
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog9
-rw-r--r--sys-apps/pmount/files/digest-pmount-0.9.163
-rw-r--r--sys-apps/pmount/pmount-0.9.16.ebuild53
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index 078627b802f6..ee36d0fa7047 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.44 2007/08/14 15:37:11 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.45 2007/09/06 08:48:53 voyageur Exp $
+
+*pmount-0.9.16 (06 Sep 2007)
+
+ 06 Sep 2007; Bernard Cafarelli <voyageur@gentoo.org>
+ +pmount-0.9.16.ebuild:
+ Version bump and fixed homepage, bug #191129
+ Should also fix bug#156063
14 Aug 2007; Benjamin Smee <strerror@gentoo.org> pmount-0.9.9.ebuild,
pmount-0.9.11.ebuild, pmount-0.9.13.ebuild:
diff --git a/sys-apps/pmount/files/digest-pmount-0.9.16 b/sys-apps/pmount/files/digest-pmount-0.9.16
new file mode 100644
index 000000000000..13e3c24b0589
--- /dev/null
+++ b/sys-apps/pmount/files/digest-pmount-0.9.16
@@ -0,0 +1,3 @@
+MD5 25fafae5d7ad3cb81bcc2131b1698f45 pmount-0.9.16.tar.gz 434647
+RMD160 38d328b3fd0ff1e5f89ad2b99fa0495a68c06eed pmount-0.9.16.tar.gz 434647
+SHA256 c44afd4498b3577bbf44ceb430e29c9b8997a8f5e4038757bcb077d58c1bc7d4 pmount-0.9.16.tar.gz 434647
diff --git a/sys-apps/pmount/pmount-0.9.16.ebuild b/sys-apps/pmount/pmount-0.9.16.ebuild
new file mode 100644
index 000000000000..0d4e1145dedf
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.16.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.16.ebuild,v 1.1 2007/09/06 08:48:53 voyageur Exp $
+
+inherit eutils
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2057/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt hal"
+
+DEPEND="hal? ( >=sys-apps/dbus-0.33 >=sys-apps/hal-0.5.2 )
+ >=sys-fs/sysfsutils-1.3.0
+ crypt? ( || ( >=sys-fs/cryptsetup-1.0.5 sys-fs/cryptsetup-luks ) )"
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_compile() {
+ econf $(use_enable hal) \
+ --with-cryptsetup-prog=/bin/cryptsetup
+ emake || die "emake failed"
+}
+
+src_install () {
+ # this is where we mount stuff
+ # moved to hal as of 0.5.7-r1
+ #keepdir /media
+
+ # Must be run SETUID
+ exeinto /usr/bin
+ exeopts -m 4710 -g plugdev
+ doexe src/pmount src/pumount src/pmount-hal
+
+ dodoc AUTHORS ChangeLog TODO
+ doman man/pmount.1 man/pumount.1 man/pmount-hal.1
+
+ insinto /etc
+ doins etc/pmount.allow
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid. The permissions are as such that"
+ elog "only users that belong to the plugdev group are allowed to run this."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}