summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-01 10:05:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-01 10:05:56 +0000
commit704fd8501ecf28dbe60d60eac3b56c14f99da92e (patch)
treeafbc165c9bb5cdc18095a2fc19c73d2306d1e6ef /sys-apps/pcsc-lite
parentSuppress warning message in elisp-site-regen for initial installation. (diff)
downloadgentoo-2-704fd8501ecf28dbe60d60eac3b56c14f99da92e.tar.gz
gentoo-2-704fd8501ecf28dbe60d60eac3b56c14f99da92e.tar.bz2
gentoo-2-704fd8501ecf28dbe60d60eac3b56c14f99da92e.zip
Version bump.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog7
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.6.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 449acc9e5a80..7ca129cf85ab 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.139 2012/08/22 12:05:45 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.140 2012/09/01 10:05:56 flameeyes Exp $
+
+*pcsc-lite-1.8.6 (01 Sep 2012)
+
+ 01 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> +pcsc-lite-1.8.6.ebuild:
+ Version bump.
22 Aug 2012; Michael Weber <xmw@gentoo.org> pcsc-lite-1.8.2.ebuild:
ppc stable (bug 411059).
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.6.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.6.ebuild
new file mode 100644
index 000000000000..063117e4b666
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.8.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.8.6.ebuild,v 1.1 2012/09/01 10:05:56 flameeyes Exp $
+
+EAPI="4"
+
+inherit multilib eutils user toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="3757"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="libusb +udev"
+
+REQUIRED_USE="^^ ( udev libusb )"
+
+CDEPEND="libusb? ( virtual/libusb:1 )
+ udev? ( sys-fs/udev )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<app-crypt/ccid-1.4.1-r1"
+
+pkg_setup() {
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /var/run/pcscd pcscd,openct
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --disable-silent-rules \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ --without-systemdsystemunitdir \
+ $(use_enable udev libudev) \
+ $(use_enable libusb) \
+ ${myconf}
+}
+
+DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
+
+src_install() {
+ default
+ prune_libtool_files
+
+ newinitd "${FILESDIR}/pcscd-init.5" pcscd
+
+ if use udev; then
+ local udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ insinto "${udevdir}"/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules; you only need to tell"
+ elog "the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}