summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-08-14 19:09:21 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-08-14 19:09:21 +0000
commit5b42bb762db0b2fa57e129c9e4d193a4b15aa101 (patch)
treeba73962025f8f80abd1ded343b7ce5617d2ef159 /sys-apps/pcsc-lite
parentStable on ppc64; bug #188796 (diff)
downloadgentoo-2-5b42bb762db0b2fa57e129c9e4d193a4b15aa101.tar.gz
gentoo-2-5b42bb762db0b2fa57e129c9e4d193a4b15aa101.tar.bz2
gentoo-2-5b42bb762db0b2fa57e129c9e4d193a4b15aa101.zip
Version bump
(Portage version: 2.1.3.5)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog7
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.43
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.4.4.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 515c5d47c512..c9b4d6ff0ff6 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.54 2007/07/25 18:25:47 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.55 2007/08/14 19:09:21 alonbl Exp $
+
+*pcsc-lite-1.4.4 (14 Aug 2007)
+
+ 14 Aug 2007; Alon Bar-Lev <alonbl@gentoo.org> +pcsc-lite-1.4.4.ebuild:
+ Version bump
25 Jul 2007; Alon Bar-Lev <alonbl@gentoo.org> -pcsc-lite-1.3.1-r1.ebuild:
Finally removing 1.3.X series
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.4 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.4
new file mode 100644
index 000000000000..e56f2334782c
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.4
@@ -0,0 +1,3 @@
+MD5 6710141d878c12d3b701dc88b9c688c0 pcsc-lite-1.4.4.tar.gz 627128
+RMD160 2feb7f76e19a30984897cf614846c00203d5a063 pcsc-lite-1.4.4.tar.gz 627128
+SHA256 9d48114ced4e32f60668f7db72231b5ce9104e460269f72f378e2fec7575291d pcsc-lite-1.4.4.tar.gz 627128
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.4.4.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.4.4.ebuild
new file mode 100644
index 000000000000..c77bcbdcc90d
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.4.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.4.4.ebuild,v 1.1 2007/08/14 19:09:21 alonbl Exp $
+
+inherit multilib
+
+STUPID_NUM="2106"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ --enable-muscledropdir="/usr/share/pcsc/services" \
+ --enable-runpid="/var/run/pcscd.pid" \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS DRIVERS HELP INSTALL README SECURITY
+ prepalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}