summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-10-26 23:37:54 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-10-26 23:37:54 +0000
commit2d7a787120deadc1d83b4d8ebe09c81fc71f10f7 (patch)
tree758d57627161620709a7334fe23bbf197a4bc163 /sys-apps/pcfclock
parentrevbump to support kernel 2.6.27, solving bug #241126. (diff)
downloadgentoo-2-2d7a787120deadc1d83b4d8ebe09c81fc71f10f7.tar.gz
gentoo-2-2d7a787120deadc1d83b4d8ebe09c81fc71f10f7.tar.bz2
gentoo-2-2d7a787120deadc1d83b4d8ebe09c81fc71f10f7.zip
removed old revision.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'sys-apps/pcfclock')
-rw-r--r--sys-apps/pcfclock/ChangeLog6
-rw-r--r--sys-apps/pcfclock/files/pcfclock-0.44-kernel-2.6.18.diff100
-rw-r--r--sys-apps/pcfclock/pcfclock-0.44-r3.ebuild54
3 files changed, 5 insertions, 155 deletions
diff --git a/sys-apps/pcfclock/ChangeLog b/sys-apps/pcfclock/ChangeLog
index f5e4095d9c51..1af08476667b 100644
--- a/sys-apps/pcfclock/ChangeLog
+++ b/sys-apps/pcfclock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pcfclock
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcfclock/ChangeLog,v 1.10 2008/10/26 23:36:23 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcfclock/ChangeLog,v 1.11 2008/10/26 23:37:54 sbriesen Exp $
+
+ 26 Oct 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ -files/pcfclock-0.44-kernel-2.6.18.diff, -pcfclock-0.44-r3.ebuild:
+ removed old revision.
*pcfclock-0.44-r5 (26 Oct 2008)
diff --git a/sys-apps/pcfclock/files/pcfclock-0.44-kernel-2.6.18.diff b/sys-apps/pcfclock/files/pcfclock-0.44-kernel-2.6.18.diff
deleted file mode 100644
index 2ac0c44b6362..000000000000
--- a/sys-apps/pcfclock/files/pcfclock-0.44-kernel-2.6.18.diff
+++ /dev/null
@@ -1,100 +0,0 @@
-diff -Naur linux.orig/pcfclock.c linux/pcfclock.c
---- linux.orig/pcfclock.c 2004-05-17 18:26:12.000000000 +0200
-+++ linux/pcfclock.c 2007-01-08 21:16:44.000000000 +0100
-@@ -49,13 +49,18 @@
- #include <linux/major.h>
- #include <linux/fs.h>
- #include <linux/sched.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
- #include <linux/devfs_fs_kernel.h>
-+#endif
- #include <linux/string.h>
- #include <linux/delay.h>
- #include <linux/parport.h>
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- #include <linux/device.h>
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
-+#include <linux/moduleparam.h>
-+#endif
-
- #include <asm/uaccess.h>
- #include <asm/semaphore.h>
-@@ -93,6 +98,26 @@
-
- static struct pcfclock_struct pcfclock_table[PCFCLOCK_NO];
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
-+# define CLASS_CREATE(owner, name) class_create(owner, name)
-+# define CLASS_DESTROY(class) class_destroy(class)
-+# define CLASS_DEVICE_CREATE(class, dev, device, fmt, rest) class_device_create(class, NULL, dev, device, fmt, rest)
-+# define CLASS_DEVICE_DESTROY(class, dev) class_device_destroy(class, dev)
-+static struct class *pcfclock_class;
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13)
-+# define CLASS_CREATE(owner, name) class_create(owner, name)
-+# define CLASS_DESTROY(class) class_destroy(class)
-+# define CLASS_DEVICE_CREATE(class, dev, device, fmt, rest) class_device_create(class, dev, device, fmt, rest)
-+# define CLASS_DEVICE_DESTROY(class, dev) class_device_destroy(class, dev)
-+static struct class *pcfclock_class;
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+# define CLASS_CREATE(owner, name) class_simple_create(owner, name)
-+# define CLASS_DESTROY(class) class_simple_destroy(class)
-+# define CLASS_DEVICE_CREATE(class, dev, device, fmt, rest) class_simple_device_add(class, dev, device, fmt, rest)
-+# define CLASS_DEVICE_DESTROY(class, dev) class_simple_device_remove(dev)
-+static struct class_simple *pcfclock_class;
-+#endif
-+
- /*
- * The radio clock transmits data only to the PC when requested. While the
- * time signal is received for the first time no communication between the PC
-@@ -401,7 +426,11 @@
- static int parport_nr[PCFCLOCK_NO] = {[0 ... PCFCLOCK_NO - 1] = PCFCLOCK_PARPORT_UNSPEC };
- static char *parport[PCFCLOCK_NO] = { NULL, };
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
-+module_param_array(parport, charp, NULL, 0);
-+#else
- MODULE_PARM(parport, "1-" __MODULE_STRING(PCFCLOCK_NO) "s");
-+#endif
-
- #ifndef MODULE
- static int __init
-@@ -442,7 +471,10 @@
- return 1;
-
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+ CLASS_DEVICE_CREATE(pcfclock_class, MKDEV(PCFCLOCK_MAJOR, n), NULL, "pcfclock%d", n);
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
- devfs_mk_cdev(MKDEV(PCFCLOCK_MAJOR, n), S_IFCHR | S_IRUGO, "pcfclocks/%d", n);
-+# endif
- #else
- sprintf(name, "%d", n);
- devfs_register(devfs_handle, name, DEVFS_FL_DEFAULT, PCFCLOCK_MAJOR, n, S_IFCHR | S_IRUGO,
-@@ -509,7 +541,10 @@
- printk(KERN_ERR "pcfclock: unable to get major %d\n", PCFCLOCK_MAJOR);
- return -EIO;
- }
-+ pcfclock_class = CLASS_CREATE(THIS_MODULE, "pcfclock");
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
- devfs_mk_dir("pcfclocks");
-+# endif
- #else
- if (devfs_register_chrdev(PCFCLOCK_MAJOR, "pcfclock", &pcfclock_fops)) {
- printk(KERN_ERR "pcfclock: unable to get major %d\n", PCFCLOCK_MAJOR);
-@@ -563,10 +598,16 @@
- for (n = 0; n < PCFCLOCK_NO; n++) {
- if (pcfclock_table[n].dev != NULL) {
- parport_unregister_device(pcfclock_table[n].dev);
-+ CLASS_DEVICE_DESTROY(pcfclock_class, MKDEV(PCFCLOCK_MAJOR, n));
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
- devfs_remove("pcfclocks/%d", n);
-+# endif
- }
- }
-+ CLASS_DESTROY(pcfclock_class);
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
- devfs_remove("pcfclocks");
-+# endif
- #else
- devfs_unregister(devfs_handle);
- devfs_unregister_chrdev(PCFCLOCK_MAJOR, "pcfclock");
diff --git a/sys-apps/pcfclock/pcfclock-0.44-r3.ebuild b/sys-apps/pcfclock/pcfclock-0.44-r3.ebuild
deleted file mode 100644
index 2af37154ed40..000000000000
--- a/sys-apps/pcfclock/pcfclock-0.44-r3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcfclock/pcfclock-0.44-r3.ebuild,v 1.2 2008/07/14 23:04:18 sbriesen Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="driver for the parallel port radio clock sold by Conrad Electronic"
-HOMEPAGE="http://www-stud.ims.uni-stuttgart.de/~voegelas/pcf.html"
-SRC_URI="http://www-stud.ims.uni-stuttgart.de/~voegelas/pcfclock/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE=""
-
-DEPEND="virtual/linux-sources"
-
-pkg_setup() {
- CONFIG_CHECK="PARPORT"
- linux-mod_pkg_setup
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-linux=${KERNEL_DIR}"
- MODULE_NAMES="pcfclock(::${S}/linux)"
- MODULESD_PCFCLOCK_ENABLED="yes"
- MODULESD_PCFCLOCK_EXAMPLES=( "pcfclock parport=0,none,none" )
- MODULESD_PCFCLOCK_ALIASES=(
- "char-major-181 pcfclock"
- "/dev/pcfclock0 char-major-181"
- "/dev/pcfclock1 char-major-181"
- "/dev/pcfclock2 char-major-181"
- )
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-kernel-2.6.18.diff"
- convert_to_m "linux/Makefile.in"
-}
-
-src_install() {
- linux-mod_src_install
- dosbin pcfdate/pcfdate
- doman {linux,pcfdate}/*.[48]
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- # Add configuration for udev
- if [ -e "${ROOT}dev/.udev" ]; then
- dodir /etc/udev/rules.d
- echo 'KERNEL=="pcfclock*", NAME="%k", MODE="0444"' \
- > "${D}/etc/udev/rules.d/55-${PN}.rules"
- fi
-}