summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-20 16:29:33 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-20 16:29:33 +0000
commit87c6726da33119b562db8dcf8398b656510326b0 (patch)
tree265d2b736f930b0a65a2c97fa6dfe8b0852eb5c8 /sys-apps/openrc
parentDie when we try to remove unknown linguas. (diff)
downloadgentoo-2-87c6726da33119b562db8dcf8398b656510326b0.tar.gz
gentoo-2-87c6726da33119b562db8dcf8398b656510326b0.tar.bz2
gentoo-2-87c6726da33119b562db8dcf8398b656510326b0.zip
Migrate to EAPI=4. Acked by William and Jeremy.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/ChangeLog5
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild43
2 files changed, 22 insertions, 26 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index 6d6045cb85f2..250a485a64c4 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.150 2011/05/13 19:06:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.151 2011/05/20 16:29:33 scarabeus Exp $
+
+ 20 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> openrc-9999.ebuild:
+ Migrate to EAPI=4. Acked by William and Jeremy.
13 May 2011; Raúl Porcel <armin76@gentoo.org> openrc-0.8.2-r1.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #295613
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 2bf78f278cbb..2b843107bb91 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.82 2011/04/17 21:02:51 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.83 2011/05/20 16:29:33 scarabeus Exp $
-EAPI="1"
+EAPI=4
-inherit eutils flag-o-matic multilib toolchain-funcs
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
+[[ ${PV} == "9999" ]] && SCM_ECLASS="git-2"
+inherit eutils flag-o-matic multilib toolchain-funcs ${SCM_ECLASS}
+unset SCM_ECLASS
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/openrc.git"
- inherit git
- KEYWORDS=""
-else
+DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
+HOMEPAGE="http://www.gentoo.org/proj/en/base/openrc/"
+if [[ ${PV} != "9999" ]] ; then
SRC_URI="mirror://gentoo/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
fi
-DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
-HOMEPAGE="http://www.gentoo.org/proj/en/base/openrc/"
-
LICENSE="BSD-2"
SLOT="0"
IUSE="debug elibc_glibc ncurses pam selinux unicode kernel_linux kernel_FreeBSD"
@@ -60,15 +58,14 @@ pkg_setup() {
export MKTERMCAP=$(usev ncurses)
}
-src_unpack() {
+src_prepare() {
+ sed -i 's:0444:0644:' mk/sys.mk || die
+ sed -i "/^DIR/s:/openrc:/${PF}:" doc/Makefile || die #241342
+
if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- else
- unpack ${A}
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
fi
- cd "${S}"
- sed -i 's:0444:0644:' mk/sys.mk
- sed -i "/^DIR/s:/openrc:/${PF}:" doc/Makefile #241342
# Allow user patches to be applied without modifying the ebuild
epatch_user
@@ -77,13 +74,8 @@ src_unpack() {
src_compile() {
make_args
- if [[ ${PV} == "9999" ]] ; then
- local ver="git-$(echo ${EGIT_VERSION} | cut -c1-8)"
- sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk
- fi
-
tc-export CC AR RANLIB
- emake ${MAKE_ARGS} || die "emake ${MAKE_ARGS} failed"
+ emake ${MAKE_ARGS}
}
# set_config <file> <option name> <yes value> <no value> test
@@ -94,13 +86,14 @@ set_config() {
[[ ${val} == "#" ]] && com="#" && val='\2'
sed -i -r -e "/^#?${var}=/{s:=([\"'])?([^ ]*)\1?:=\1${val}\1:;s:^#?:${com}:}" "${file}"
}
+
set_config_yes_no() {
set_config "$1" "$2" YES NO "${@:3}"
}
src_install() {
make_args
- emake ${MAKE_ARGS} DESTDIR="${D}" install || die
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
# install the readme for the new network scripts
dodoc README.newnet