summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-07-30 16:31:16 +0000
committerDan Armak <danarmak@gentoo.org>2001-07-30 16:31:16 +0000
commit958b40764eae1349cfdf883697a78eedb8277a57 (patch)
tree94ecfab96d3e2fb690d8a7cba2cc41cfc5041edd /sys-apps/noflushd
parentNow uses /etc/rc.d/config/noflushd.conf instead of /etc/noflushd.conf. Upgrad... (diff)
downloadgentoo-2-958b40764eae1349cfdf883697a78eedb8277a57.tar.gz
gentoo-2-958b40764eae1349cfdf883697a78eedb8277a57.tar.bz2
gentoo-2-958b40764eae1349cfdf883697a78eedb8277a57.zip
Part of previous commit
Diffstat (limited to 'sys-apps/noflushd')
-rw-r--r--sys-apps/noflushd/files/digest-noflushd-2.4-r11
-rw-r--r--sys-apps/noflushd/noflushd-2.4-r1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/noflushd/files/digest-noflushd-2.4-r1 b/sys-apps/noflushd/files/digest-noflushd-2.4-r1
new file mode 100644
index 000000000000..aacb22f941a8
--- /dev/null
+++ b/sys-apps/noflushd/files/digest-noflushd-2.4-r1
@@ -0,0 +1 @@
+MD5 b248ff04030ffa79a14ef76f3d0ff8f0 noflushd_2.4.orig.tar.gz
diff --git a/sys-apps/noflushd/noflushd-2.4-r1.ebuild b/sys-apps/noflushd/noflushd-2.4-r1.ebuild
new file mode 100644
index 000000000000..95dd0bb981e0
--- /dev/null
+++ b/sys-apps/noflushd/noflushd-2.4-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/noflushd/noflushd-2.4-r1.ebuild,v 1.1 2001/07/30 16:31:16 danarmak Exp $
+# Note: the daemon's current 2.4 version has nothing to do with kernel versions
+
+#P=""
+A=noflushd_2.4.orig.tar.gz
+S=${WORKDIR}/${P}.orig
+SRC_URI="http://download.suorceforge.net/noflushd/${A}"
+
+HOMEPAGE="http://noflushd.sourceforge.net"
+DESCRIPTION="A daemon to spin down your disks and force accesses to be cached"
+
+# Stop being lazy and check real deps for building
+DEPEND=""
+
+src_compile() {
+
+ confopts="--infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} --with-docdir=/usr/share/doc/${P}"
+
+ try ./configure ${confopts}
+
+ try emake
+
+}
+
+src_install () {
+
+ # The orig. noflushd includes startup scripts for suse, debian and redhat.
+ # It detects gentoo as redhat (at least here it does), and in any case
+ # we don't want any of its rc.d scripts, so we install manually. There's
+ # only one binary and the docs.
+
+ cd ${S}
+
+ into /usr
+ dosbin src/noflushd
+ doman man/noflushd.8
+
+ dodoc README NEWS
+
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/noflushd
+
+ insinto /etc/rc.d/config
+ # update from previous (-r0) location of config file
+ if [ -x /etc/noflushd.conf ] ;
+ then
+ doins /etc/noflushd.conf
+ else
+ doins ${FILESDIR}/noflushd.conf
+ fi
+
+}
+
+pkg_postinst() {
+
+ echo "
+ Run 'rc-update add noflushd' to add it to runlevels 2 3 4.
+
+ Edit /etc/noflushd.conf to change the default spindown
+ timeout and the disks handled; the defaults are 60 minutes
+ and /dev/discs/disc0/disc (i.e. hda).
+
+ NOTE FOR UPDATE:
+ The original version of this ebuild used /etc/env.d/70noflushd
+ for settings, the next version used /etc/noflushd.conf, and finally
+ this new version (-r1) uses /etc/rc.d/config/noflushd.conf. If you
+ had a config file in the previous location and none in the new one,
+ it will have been copied to the new one (the syntax is identical).
+
+ If you updated, you MUST go to /etc/rc.d/init.d and replace the old
+ noflushd init script with the new one if you have the default config
+ dir protection!
+
+ WARNING:
+ WARNING: Do NOT use with SCSI, unstable!
+ WARNING:
+ "
+
+} \ No newline at end of file