summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2005-01-10 23:40:02 +0000
committerGuy Martin <gmsoft@gentoo.org>2005-01-10 23:40:02 +0000
commitbca086a9bb7e6ce414f790b35ca965a45f008fd4 (patch)
treeb7be0075104f553d7d3ad389deac676403df81e9 /sys-apps/netboot-base
parentYes we *NEED* the symlinks for netboot. (Manifest recommit) (diff)
downloadgentoo-2-bca086a9bb7e6ce414f790b35ca965a45f008fd4.tar.gz
gentoo-2-bca086a9bb7e6ce414f790b35ca965a45f008fd4.tar.bz2
gentoo-2-bca086a9bb7e6ce414f790b35ca965a45f008fd4.zip
Fix syntax errors in functions.sh and fix kill of syslogd and devfsd.
Diffstat (limited to 'sys-apps/netboot-base')
-rw-r--r--sys-apps/netboot-base/ChangeLog9
-rw-r--r--sys-apps/netboot-base/Manifest12
-rw-r--r--sys-apps/netboot-base/files/digest-netboot-base-200501101
-rw-r--r--sys-apps/netboot-base/netboot-base-20050110.ebuild43
4 files changed, 53 insertions, 12 deletions
diff --git a/sys-apps/netboot-base/ChangeLog b/sys-apps/netboot-base/ChangeLog
index 2df15368f575..c0b5c6f01ad2 100644
--- a/sys-apps/netboot-base/ChangeLog
+++ b/sys-apps/netboot-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/netboot-base
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/ChangeLog,v 1.3 2004/10/07 21:00:08 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/ChangeLog,v 1.4 2005/01/10 23:40:02 gmsoft Exp $
+
+*netboot-base-20050110 (11 Jan 2005)
+
+ 11 Jan 2005; Guy Martin <gmsoft@gentoo.org> +netboot-base-20050110.ebuild:
+ Fix syntax errors in functions.sh and fix kill of syslogd and devfsd.
*netboot-base-* (06 Oct 2004)
diff --git a/sys-apps/netboot-base/Manifest b/sys-apps/netboot-base/Manifest
index 4c31d9b74e7f..384507580734 100644
--- a/sys-apps/netboot-base/Manifest
+++ b/sys-apps/netboot-base/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 d4969be6b3f1725977e3e6774a050257 ChangeLog 341
MD5 607dc51d1f0bcebda4b8fe238ddb7734 metadata.xml 286
MD5 f75b672a5201cd146f46c712cb576445 netboot-base-20041007.ebuild 977
+MD5 f75b672a5201cd146f46c712cb576445 netboot-base-20050110.ebuild 977
MD5 70bab51ddf543bb3c33317914b4c5fa3 files/digest-netboot-base-20041007 72
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFB2wsvroRuSHgZdywRAn8zAJ9imftC3SYhg7w9F7yl6Aqy8TjQPACfaQ0Y
-3/GcdEW/npfrMr/2K/ebTBo=
-=NnEY
------END PGP SIGNATURE-----
+MD5 8b9d4de8e410cd177be0fc1e26005ac4 files/digest-netboot-base-20050110 72
diff --git a/sys-apps/netboot-base/files/digest-netboot-base-20050110 b/sys-apps/netboot-base/files/digest-netboot-base-20050110
new file mode 100644
index 000000000000..58dd3ae64270
--- /dev/null
+++ b/sys-apps/netboot-base/files/digest-netboot-base-20050110
@@ -0,0 +1 @@
+MD5 c652d65b218f1e61cf1ee1aafe7f9c72 netboot-base-20050110.tar.bz2 4313
diff --git a/sys-apps/netboot-base/netboot-base-20050110.ebuild b/sys-apps/netboot-base/netboot-base-20050110.ebuild
new file mode 100644
index 000000000000..f59a1f82714c
--- /dev/null
+++ b/sys-apps/netboot-base/netboot-base-20050110.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/netboot-base-20050110.ebuild,v 1.1 2005/01/10 23:40:02 gmsoft Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Baselayout for netboot systems"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~vapier/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ [[ ${ROOT} = "/" ]] && die "refusing to emerge to /"
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} src/consoletype.c -o sbin/consoletype || die
+ $(tc-getSTRIP) --strip-unneeded sbin/consoletype
+}
+
+src_install() {
+ [[ ${ROOT} = "/" ]] && die "refusing to install to /"
+ rm -r src
+ cp -r * ${D}/
+}
+
+pkg_postinst() {
+ cd "${ROOT}"
+ mkdir -p bin dev etc lib mnt proc sbin var
+ mkdir -p var/log
+ mkdir -p mnt/gentoo
+ ln -s . usr
+ ln -s . share
+}