summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-23 23:13:09 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-23 23:13:09 +0000
commitc602d3f4c638626fb335e78db2d17d29acdfd666 (patch)
tree688ef92522278cdf5504d6a29e9517cb10565524 /sys-apps/modutils/modutils-2.4.23.ebuild
parentMoving to sci-biology/embassy (diff)
downloadgentoo-2-c602d3f4c638626fb335e78db2d17d29acdfd666.tar.gz
gentoo-2-c602d3f4c638626fb335e78db2d17d29acdfd666.tar.bz2
gentoo-2-c602d3f4c638626fb335e78db2d17d29acdfd666.zip
old
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.23.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.23.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sys-apps/modutils/modutils-2.4.23.ebuild b/sys-apps/modutils/modutils-2.4.23.ebuild
deleted file mode 100644
index 2fbe68843c34..000000000000
--- a/sys-apps/modutils/modutils-2.4.23.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.23.ebuild,v 1.15 2004/09/03 21:03:24 pvdabeel Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="Standard kernel module utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
-SRC_URI="mirror://kernel/linux/utils/kernel/modutils/v2.4/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -amd64 ppc ~sparc ~alpha ~hppa ~mips"
-IUSE=""
-
-DEPEND="virtual/libc
- !virtual/modutils"
-PROVIDE="virtual/modutils"
-
-src_compile() {
- filter-flags -fPIC
-
- myconf=""
- # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
- #
- # Final resolution ... dont make it link against zlib, as the static
- # version do not want to autoload modules :(
- myconf="${myconf} --disable-zlib"
-
- econf \
- --prefix=/ \
- --disable-strip \
- --enable-insmod-static \
- ${myconf} || die "./configure failed"
- if [ ${ARCH} = "hppa" ]
- then
- mymake="ARCH=hppa"
- fi
-
- emake ${mymake} || die "emake failed"
-}
-
-src_install() {
- if [ ${ARCH} = "hppa" ]
- then
- mymake="ARCH=hppa"
- fi
- einstall prefix="${D}" ${mymake} || die "make install failed"
-
- dodoc COPYING CREDITS ChangeLog NEWS README TODO
-}
-
-pkg_postinst() {
- echo
- einfo "If you get problems after update related to missing"
- einfo "\"keybdev\" module, please recompile your kernel."
- echo
-}