summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-21 15:49:29 +0000
committerNed Ludd <solar@gentoo.org>2004-06-21 15:49:29 +0000
commit1fc3145d581ea565eec6d7ed475824908a4e5a91 (patch)
tree8d70d7c10c5f0bdb62134a7dca87a63ee5242b32 /sys-apps/miscfiles/miscfiles-1.3-r1.ebuild
parentAdd some info about needing ~/.wine to run things. Bug #54644 (Manifest reco... (diff)
downloadgentoo-2-1fc3145d581ea565eec6d7ed475824908a4e5a91.tar.gz
gentoo-2-1fc3145d581ea565eec6d7ed475824908a4e5a91.tar.bz2
gentoo-2-1fc3145d581ea565eec6d7ed475824908a4e5a91.zip
clean unneeded things in a native-uclibc envionment. Added dep of gzip and glibc
Diffstat (limited to 'sys-apps/miscfiles/miscfiles-1.3-r1.ebuild')
-rw-r--r--sys-apps/miscfiles/miscfiles-1.3-r1.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/sys-apps/miscfiles/miscfiles-1.3-r1.ebuild b/sys-apps/miscfiles/miscfiles-1.3-r1.ebuild
index 1dff80a56f96..52adcf49b238 100644
--- a/sys-apps/miscfiles/miscfiles-1.3-r1.ebuild
+++ b/sys-apps/miscfiles/miscfiles-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/miscfiles/miscfiles-1.3-r1.ebuild,v 1.8 2004/04/26 04:55:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/miscfiles/miscfiles-1.3-r1.ebuild,v 1.9 2004/06/21 15:49:29 solar Exp $
inherit eutils
@@ -11,7 +11,10 @@ SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE=""
+IUSE="uclibc"
+
+DEPEND="virtual/glibc
+ uclibc? ( app-arch/gzip )"
src_unpack() {
unpack ${A}
@@ -23,4 +26,19 @@ src_unpack() {
src_install() {
einstall || die
dodoc GNU* NEWS ORIGIN README dict-README
+
+ if use uclibc ; then
+ cd ${D}/usr/share/dict
+ # need to remove the hardlinks, else gzip won't work
+ rm -f words extra.words README
+ gzip -9 *
+ ln -s web2.gz words
+ ln -s web2a.gz extra.words
+ cd ..
+ # which app uses these?
+ rm -rf misc state rfc
+ #rm -f misc/GNU-manifesto
+ #gzip -9 misc/* state/* rfc/*
+ cd ${S}
+ fi
}