summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-15 00:45:07 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-15 00:45:07 +0000
commitfa556d659c410ec158a5c13febef144918b64e59 (patch)
treebaae15fd4f91ddbe1aedf794ac4b196fc54f46cb /sys-apps/microcode-ctl
parentversion bump (bug #105522) (diff)
downloadgentoo-2-fa556d659c410ec158a5c13febef144918b64e59.tar.gz
gentoo-2-fa556d659c410ec158a5c13febef144918b64e59.tar.bz2
gentoo-2-fa556d659c410ec158a5c13febef144918b64e59.zip
Version bump.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog10
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.121
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.12.ebuild47
3 files changed, 56 insertions, 2 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index e15491a9b130..5c5187fc2212 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-ctl
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.12 2005/01/10 03:55:43 swtaylor Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.13 2005/09/15 00:45:07 vapier Exp $
+
+*microcode-ctl-1.12 (15 Sep 2005)
+
+ 15 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +microcode-ctl-1.12.ebuild:
+ Version bump.
09 Jan 2005; Scott W Taylor <swtaylor@gentoo.org>
microcode-ctl-1.11.ebuild:
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.12 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.12
new file mode 100644
index 000000000000..569c87c4cda8
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.12
@@ -0,0 +1 @@
+MD5 07d5f64b7c84a00663425089221d5fb0 microcode_ctl-1.12.tar.gz 239762
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.12.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.12.ebuild
new file mode 100644
index 000000000000..a15c87c6902e
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.12.ebuild,v 1.1 2005/09/15 00:45:07 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/os-headers
+ >=sys-apps/portage-2.0.51"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ insinto /etc
+ newins intel-ia32microcode-*.txt microcode.dat
+
+ newinitd "${FILESDIR}"/microcode_ctl.rc microcode_ctl
+ newconfd "${FILESDIR}"/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}