summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-28 10:54:23 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-28 10:54:23 +0000
commitfc610f7835465a928212c21c102d03e70c2f0369 (patch)
treecfe85e06d8b33fd9726d68e3960d3ee115128d4e /sys-apps/memtest86+
parentBump (diff)
downloadgentoo-2-fc610f7835465a928212c21c102d03e70c2f0369.tar.gz
gentoo-2-fc610f7835465a928212c21c102d03e70c2f0369.tar.bz2
gentoo-2-fc610f7835465a928212c21c102d03e70c2f0369.zip
Compile memtest86+ with -O1 instead of -Os (bug #217324).
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'sys-apps/memtest86+')
-rw-r--r--sys-apps/memtest86+/ChangeLog6
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch4
2 files changed, 7 insertions, 3 deletions
diff --git a/sys-apps/memtest86+/ChangeLog b/sys-apps/memtest86+/ChangeLog
index da6e1263fd9d..91dd6387029e 100644
--- a/sys-apps/memtest86+/ChangeLog
+++ b/sys-apps/memtest86+/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/memtest86+
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.41 2008/08/23 06:12:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.42 2008/09/28 10:54:22 spock Exp $
+
+ 28 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ files/memtest86+-2.01-hardcoded_cc.patch:
+ Compile memtest86+ with -O1 instead of -Os (bug #217324).
23 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch
index c2e2ee491f70..3b07731daadd 100644
--- a/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch
+++ b/sys-apps/memtest86+/files/memtest86+-2.01-hardcoded_cc.patch
@@ -10,7 +10,7 @@ diff -Naurp memtest86+-2.01-orig/Makefile memtest86+-2.01/Makefile
-
-CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
+CPPFLAGS=-m32
-+CFLAGS=-Wall -m32 -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
++CFLAGS=-Wall -m32 -march=i486 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
+ASFLAGS=-32
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
@@ -24,7 +24,7 @@ diff -Naurp memtest86+-2.01-orig/Makefile memtest86+-2.01/Makefile
test.o: test.c
- $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
-+ $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector -fno-pie -nopie test.c
++ $(CC) -c -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector -fno-pie -nopie test.c
clean:
rm -f *.o *.s *.iso memtest.bin memtest memtest_shared memtest_shared.bin