summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-02-10 19:18:54 +0000
committerMichael Januszewski <spock@gentoo.org>2008-02-10 19:18:54 +0000
commit520b39adb92e3fa9e2138bc03fcc279aa3679f72 (patch)
tree8e4bcded409d9932f406db92d0831f9164cbd685 /sys-apps/memtest86+
parentVersion bump to 1.2.2_beta as per bug 200185. (diff)
downloadgentoo-2-520b39adb92e3fa9e2138bc03fcc279aa3679f72.tar.gz
gentoo-2-520b39adb92e3fa9e2138bc03fcc279aa3679f72.tar.bz2
gentoo-2-520b39adb92e3fa9e2138bc03fcc279aa3679f72.zip
Version bump (bug #209525).
(Portage version: 2.1.4.1)
Diffstat (limited to 'sys-apps/memtest86+')
-rw-r--r--sys-apps/memtest86+/ChangeLog10
-rw-r--r--sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch25
-rw-r--r--sys-apps/memtest86+/memtest86+-2.00.ebuild69
3 files changed, 102 insertions, 2 deletions
diff --git a/sys-apps/memtest86+/ChangeLog b/sys-apps/memtest86+/ChangeLog
index df506e305fa3..c8c60a28d31b 100644
--- a/sys-apps/memtest86+/ChangeLog
+++ b/sys-apps/memtest86+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/memtest86+
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.37 2007/03/17 12:52:53 beandog Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.38 2008/02/10 19:18:53 spock Exp $
+
+*memtest86+-2.00 (10 Feb 2008)
+
+ 10 Feb 2008; Michał Januszewski <spock@gentoo.org>
+ +files/memtest86+-2.00-hardcoded_cc.patch, +memtest86+-2.00.ebuild:
+ Version bump (bug #209525).
17 Mar 2007; Steve Dibb <beandog@gentoo.org> memtest86+-1.70.ebuild:
amd64 stable, bug 168486
diff --git a/sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch
new file mode 100644
index 000000000000..449b1bf3ddec
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-2.00-hardcoded_cc.patch
@@ -0,0 +1,25 @@
+diff -Naurp memtest86+-2.00-orig/Makefile memtest86+-2.00/Makefile
+--- memtest86+-2.00-orig/Makefile 2008-02-10 19:50:30.000000000 +0100
++++ memtest86+-2.00/Makefile 2008-02-10 20:05:30.000000000 +0100
+@@ -8,9 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-CC=gcc
+-
+-CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
++CPPFLAGS=-m32
++CFLAGS=-Wall -m32 -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector
++ASFLAGS=-32
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
+@@ -37,7 +37,7 @@ memtest.bin: memtest_shared.bin bootsect
+ memtest_shared.bin -o memtest.bin
+
+ reloc.o: reloc.c
+- $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
++ $(CC) -c $(CFLAGS) -fno-strict-aliasing -fno-stack-protector reloc.c
+
+ test.o: test.c
+ $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
diff --git a/sys-apps/memtest86+/memtest86+-2.00.ebuild b/sys-apps/memtest86+/memtest86+-2.00.ebuild
new file mode 100644
index 000000000000..129aee2b29bc
--- /dev/null
+++ b/sys-apps/memtest86+/memtest86+-2.00.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-2.00.ebuild,v 1.1 2008/02/10 19:18:53 spock Exp $
+
+inherit mount-boot eutils
+
+DESCRIPTION="Memory tester based on memtest86"
+HOMEPAGE="http://www.memtest.org/"
+SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-hardcoded_cc.patch
+ epatch "${FILESDIR}"/${PN}-1.70-gnu_hash.patch
+
+ if use serial ; then
+ sed -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' -i config.h
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ insinto /boot/memtest86plus
+ doins memtest.bin || die
+ dodoc README README.build-process
+}
+
+pkg_postinst() {
+ einfo
+ einfo "memtest.bin has been installed in /boot/memtest86plus/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+
+ # a little magic to make users' life as easy as possible ;)
+ local fstab=${ROOT}/etc/fstab
+ local root="(hd0,0)"
+ local res=$(awk '$2 == "/boot" {print $1}' "${fstab}")
+ if [[ -z ${res} ]] ; then
+ res=$(awk '$2 == "/" {print $1}' "${fstab}")
+ fi
+ if [[ -n ${res} ]] ; then
+ # transform /dev/hd* magic into grub naming ...
+ # /dev/hda1 -> a1 -> 01
+ root=$(echo "${res}" | grep -o '[a-z][0-9]' | tr -t a-z 0123456789)
+ root="(hd${root:0:1},$((${root:1:1}-1)))"
+ fi
+ einfo " - For grub:"
+ einfo " > title=Memtest86Plus"
+ einfo " > root ${root}"
+ einfo " > kernel /boot/memtest86plus/memtest.bin"
+
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86plus/memtest.bin"
+ einfo " > label = Memtest86Plus"
+ einfo
+}