summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-01-24 10:37:47 +0000
committerMichael Januszewski <spock@gentoo.org>2005-01-24 10:37:47 +0000
commit01283614188151a0e336425a5ef5a5778fcdbe50 (patch)
tree9b34bf318dfbba6ce03ab56425afa1e7b19d35b7 /sys-apps/memtest86+
parentFixed DEPEND and added bugfix for PaX (rsbac bugfix-5) (Manifest recommit) (diff)
downloadgentoo-2-01283614188151a0e336425a5ef5a5778fcdbe50.tar.gz
gentoo-2-01283614188151a0e336425a5ef5a5778fcdbe50.tar.bz2
gentoo-2-01283614188151a0e336425a5ef5a5778fcdbe50.zip
Added a patch that fixes compilation on hardened systems. Closes bug #73383.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'sys-apps/memtest86+')
-rw-r--r--sys-apps/memtest86+/ChangeLog7
-rw-r--r--sys-apps/memtest86+/files/memtest86+-1.50-hardened.patch24
-rw-r--r--sys-apps/memtest86+/memtest86+-1.40.ebuild5
-rw-r--r--sys-apps/memtest86+/memtest86+-1.50.ebuild7
4 files changed, 38 insertions, 5 deletions
diff --git a/sys-apps/memtest86+/ChangeLog b/sys-apps/memtest86+/ChangeLog
index b7dea78fd65d..83216c830a53 100644
--- a/sys-apps/memtest86+/ChangeLog
+++ b/sys-apps/memtest86+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/memtest86+
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.16 2005/01/22 15:16:13 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/ChangeLog,v 1.17 2005/01/24 10:37:47 spock Exp $
+
+ 24 Jan 2005; Michał Januszewski <spock@gentoo.org>
+ +files/memtest86+-1.50-hardened.patch, memtest86+-1.40.ebuild,
+ memtest86+-1.50.ebuild:
+ Added a patch that fixes compilation on hardened systems. Closes bug #73383.
*memtest86+-1.50 (22 Jan 2005)
diff --git a/sys-apps/memtest86+/files/memtest86+-1.50-hardened.patch b/sys-apps/memtest86+/files/memtest86+-1.50-hardened.patch
new file mode 100644
index 000000000000..3501a7cfa6f6
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-1.50-hardened.patch
@@ -0,0 +1,24 @@
+--- Makefile.orig 2005-01-23 10:17:43.000000000 -0500
++++ Makefile 2005-01-23 10:18:07.000000000 -0500
+@@ -12,7 +12,7 @@
+ #
+ # gcc compiler options, these settings should suffice
+ #
+-CCFLAGS=-Wall -m32 -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding
++CCFLAGS=-Wall -m32 -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector
+
+ AS=as -32
+
+@@ -21,10 +21,10 @@
+ all: memtest.bin memtest
+
+ reloc.o: reloc.c
+- $(CC) -c -m32 -march=i486 -fPIC -Wall -g -O2 -fno-strict-aliasing reloc.c
++ $(CC) -c -m32 -march=i486 -fPIC -Wall -g -O2 -fno-strict-aliasing reloc.c -fno-stack-protector
+
+ test.o: test.c test.h defs.h config.h
+- $(CC) -c $(CCFLAGS) test.c
++ $(CC) -c $(CCFLAGS) -fno-PIC test.c
+
+ main.o: main.c test.h defs.h
+ $(CC) -c $(CCFLAGS) -fPIC main.c
diff --git a/sys-apps/memtest86+/memtest86+-1.40.ebuild b/sys-apps/memtest86+/memtest86+-1.40.ebuild
index 631ec31d68ca..7b5c41ce1181 100644
--- a/sys-apps/memtest86+/memtest86+-1.40.ebuild
+++ b/sys-apps/memtest86+/memtest86+-1.40.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-1.40.ebuild,v 1.2 2005/01/22 15:16:13 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-1.40.ebuild,v 1.3 2005/01/24 10:37:47 spock Exp $
-inherit mount-boot
+inherit mount-boot eutils
DESCRIPTION="Memory tester based on memtest86"
HOMEPAGE="http://www.memtest.org/"
@@ -17,6 +17,7 @@ src_unpack() {
unpack ${A}
cd ${S}
+ epatch "${FILESDIR}"/${PN}-1.50-hardened.patch
if use serial ; then
sed -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' -i config.h
fi
diff --git a/sys-apps/memtest86+/memtest86+-1.50.ebuild b/sys-apps/memtest86+/memtest86+-1.50.ebuild
index 58607154df7d..f33b4adb77e7 100644
--- a/sys-apps/memtest86+/memtest86+-1.50.ebuild
+++ b/sys-apps/memtest86+/memtest86+-1.50.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-1.50.ebuild,v 1.1 2005/01/22 15:16:13 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-1.50.ebuild,v 1.2 2005/01/24 10:37:47 spock Exp $
-inherit mount-boot
+inherit mount-boot eutils
DESCRIPTION="Memory tester based on memtest86"
HOMEPAGE="http://www.memtest.org/"
@@ -17,6 +17,9 @@ src_unpack() {
unpack ${A}
cd ${S}
+ # send the DOS newlines where they belong - /dev/null ;>
+ sed -e 's/\x0d//g' -i Makefile
+ epatch "${FILESDIR}"/${P}-hardened.patch
if use serial ; then
sed -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' -i config.h
fi