summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-13 04:01:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-13 04:01:35 +0000
commitb060315bf187287ea803a323e42120c6eff51bc6 (patch)
tree20d9a7dcc560d3c4d3bacc00511805613d43c001 /sys-apps/man
parentStable on x86 wrt bug #111968. (diff)
downloadgentoo-2-b060315bf187287ea803a323e42120c6eff51bc6.tar.gz
gentoo-2-b060315bf187287ea803a323e42120c6eff51bc6.tar.bz2
gentoo-2-b060315bf187287ea803a323e42120c6eff51bc6.zip
old
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/files/digest-man-1.6b1
-rw-r--r--sys-apps/man/man-1.6b.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/sys-apps/man/files/digest-man-1.6b b/sys-apps/man/files/digest-man-1.6b
deleted file mode 100644
index d165bbd8d8a6..000000000000
--- a/sys-apps/man/files/digest-man-1.6b
+++ /dev/null
@@ -1 +0,0 @@
-MD5 81d96091482b6445cbfa248fadb422b8 man-1.6b.tar.gz 238993
diff --git a/sys-apps/man/man-1.6b.ebuild b/sys-apps/man/man-1.6b.ebuild
deleted file mode 100644
index 783534367dc4..000000000000
--- a/sys-apps/man/man-1.6b.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6b.ebuild,v 1.1 2005/11/10 23:49:58 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard commands to read man pages"
-HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
-SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls"
-
-DEPEND=""
-RDEPEND="sys-process/cronbase
- >=sys-apps/groff-1.18
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- enewgroup man 15
- enewuser man 13 -1 /usr/share/man man
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # We love to cross-compile
- epatch "${FILESDIR}"/man-1.6-cross-compile.patch
- epatch "${FILESDIR}"/man-1.6b-build.patch
-
- # Fix search order in man.conf so that system installed manpages
- # will be found first ...
- epatch "${FILESDIR}"/man-1.5p-search-order.patch
-
- # For groff-1.18 or later we need to call nroff with '-c'
- epatch "${FILESDIR}"/man-1.5m-groff-1.18.patch
-
- # makewhatis traverses manpages twice, as default manpath
- # contains two directories that are symlinked together
- epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
-
- # makewhatis should get section info from config, not hardcode it #86863
- epatch "${FILESDIR}"/man-1.6a-makewhatis-config.patch
-
- # Fedora patches
- epatch "${FILESDIR}"/man-1.5m2-apropos.patch
- epatch "${FILESDIR}"/man-1.5p-man2html.patch
- epatch "${FILESDIR}"/man-1.5p-mandirlist.patch
-
- # use non-lazy binds for man
- append-ldflags -Wl,-z,now
-
- strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
-}
-
-src_compile() {
- tc-export CC BUILD_CC
-
- local mylang=
- if use nls ; then
- if [[ -z ${LINGUAS} ]] ; then
- mylang="all"
- else
- mylang="${LINGUAS// /,}"
- fi
- else
- mylang="none"
- fi
- ./configure \
- -confdir=/etc \
- +sgid +fhs \
- +lang ${mylang} \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make PREFIX="${D}" install || die "make install failed"
- dosym man /usr/bin/manpath
-
- dodoc LSM README* TODO
-
- exeinto /etc/cron.weekly
- newexe "${FILESDIR}"/makewhatis.cron makewhatis
-
- keepdir /var/cache/man
- diropts -m0775 -g man
- local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
- for x in ${mansects//:/ } ; do
- keepdir /var/cache/man/cat${x}
- done
-}
-
-pkg_postinst() {
- einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
- chown -R root:man "${ROOT}"/var/cache/man
- chmod -R g+w "${ROOT}"/var/cache/man
- [[ -e ${ROOT}/var/cache/man/whatis ]] \
- && chown root:root "${ROOT}"/var/cache/man/whatis
-
- echo
-
- local files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
- if [[ ${files/$'\n'} != ${files} ]] ; then
- ewarn "You have multiple makewhatis cron files installed."
- ewarn "You might want to delete all but one of these:"
- echo ${files}
- fi
-}