summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-29 05:12:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-29 05:12:10 +0000
commit66902b8e639e813948b32b0c35f51130a3ad2e0f (patch)
tree6a5db4315b217d2e062935bdd3f038ecde63be62 /sys-apps/man
parentdont forget virtual/os-headers (diff)
downloadgentoo-2-66902b8e639e813948b32b0c35f51130a3ad2e0f.tar.gz
gentoo-2-66902b8e639e813948b32b0c35f51130a3ad2e0f.tar.bz2
gentoo-2-66902b8e639e813948b32b0c35f51130a3ad2e0f.zip
move the manpage perm fixes into pkg_postinst() #40322
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/man-1.5m-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-apps/man/man-1.5m-r1.ebuild b/sys-apps/man/man-1.5m-r1.ebuild
index 7d2f430c6fb7..af90b8d77eb5 100644
--- a/sys-apps/man/man-1.5m-r1.ebuild
+++ b/sys-apps/man/man-1.5m-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r1.ebuild,v 1.8 2004/06/30 02:52:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r1.ebuild,v 1.9 2004/07/29 05:12:10 vapier Exp $
inherit eutils
@@ -121,6 +121,13 @@ src_install() {
}
pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man ${ROOT}/var/cache/man
+ chmod -R g+w ${ROOT}/var/cache/man
+ [ -e ${ROOT}/var/cache/man/whatis ] && chown root:root ${ROOT}/var/cache/man/whatis
+
+ echo
+
local files="`ls ${ROOT}/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null`"
if [ "${files/$'\n'}" != "${files}" ] ; then
ewarn "You have multiple makewhatis cron files installed."