summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-11 04:14:11 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-11 04:14:11 +0000
commit0d63a4ddd9d9f2703d706ae92483475450c2d12d (patch)
tree71491591c0cb13888c960e3c9933420dff1804f9 /sys-apps/man
parent+dev-libs/libtomcrypt:libtommath +dev-libs/libtomcrypt:tomsfastmath (diff)
downloadgentoo-2-0d63a4ddd9d9f2703d706ae92483475450c2d12d.tar.gz
gentoo-2-0d63a4ddd9d9f2703d706ae92483475450c2d12d.tar.bz2
gentoo-2-0d63a4ddd9d9f2703d706ae92483475450c2d12d.zip
Fix cross-compile support.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog6
-rw-r--r--sys-apps/man/files/man-1.6-cross-compile.patch61
-rw-r--r--sys-apps/man/man-1.6-r1.ebuild5
3 files changed, 70 insertions, 2 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 3918b87ee4d2..d966b2450c5c 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.72 2005/07/09 22:49:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.73 2005/08/11 04:09:38 vapier Exp $
+
+ 11 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.6-cross-compile.patch, man-1.6-r1.ebuild:
+ Fix cross-compile support.
*man-1.6-r1 (09 Jul 2005)
diff --git a/sys-apps/man/files/man-1.6-cross-compile.patch b/sys-apps/man/files/man-1.6-cross-compile.patch
new file mode 100644
index 000000000000..184236918b91
--- /dev/null
+++ b/sys-apps/man/files/man-1.6-cross-compile.patch
@@ -0,0 +1,61 @@
+Fix up to work with cross-compiling ... most of these tests only
+need to see if the example compiled, not whether it runs ...
+
+--- configure
++++ configure
+@@ -232,15 +232,13 @@
+
+ echo checking for POSIX.1 header files
+ echo "#include <unistd.h>
+-main() {
+ #ifdef _POSIX_VERSION
+-exit(0);
++main() { exit(0); }
+ #else
+-exit(1);
+-#endif
+-}" > conftest.c
++# error no _POSIX_VERSION
++#endif" > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then
++if test -s conftest ; then
+ DEFS="$DEFS -DPOSIX"
+ fi
+ rm -f conftest conftest.c
+@@ -249,7 +247,7 @@
+ echo "#include <strings.h>
+ main() { exit(0); rindex(0, 0); bzero(0, 0); }" > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then :
++if test -s conftest ; then :
+ else DEFS="$DEFS -DUSG"
+ fi
+ rm -f conftest conftest.c
+@@ -258,7 +256,7 @@
+ echo '#include <sys/types.h>
+ main() { uid_t x; exit(0); }' > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then :
++if test -s conftest ; then :
+ else
+ uid_t=`awk '/pw_uid;/ {print $1}' $INCLUDEDIR/pwd.h`
+ DEFS="$DEFS -Duid_t=${uid_t} -Dgid_t=${uid_t}"
+@@ -291,7 +289,7 @@
+ #endif
+ main() { char *p = (char *) alloca(1); exit(0); }' > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then :
++if test -s conftest ; then :
+ elif test -d /usr/ucblib; then LIBS="$LIBS -L/usr/ucblib -lucb"
+ elif test -f /usr/lib/libPW.a; then LIBS="$LIBS -lPW"
+ else DEFS="$DEFS -DALLOCA_MISSING"
+@@ -321,7 +319,7 @@
+ struct option long_opts[] = { { "", no_argument, NULL, 0 } };
+ main() { exit(0); }' > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then
++if test -s conftest ; then
+ manpathoption="--path"
+ else
+ manpathoption="-w"
diff --git a/sys-apps/man/man-1.6-r1.ebuild b/sys-apps/man/man-1.6-r1.ebuild
index 330aaadf5ad5..9db2e6e5ef93 100644
--- a/sys-apps/man/man-1.6-r1.ebuild
+++ b/sys-apps/man/man-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6-r1.ebuild,v 1.1 2005/07/09 22:49:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6-r1.ebuild,v 1.2 2005/08/11 04:09:38 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -25,6 +25,9 @@ src_unpack() {
# Make sure we can build with -j :)
epatch "${FILESDIR}"/man-1.6-parallel-make.patch
+ # We love to cross-compile
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+
# Fix message order in en lang file which triggers segv's for
# non-english users #97541
epatch "${FILESDIR}"/man-1.6-message-order.patch