summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-27 18:35:39 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-27 18:35:39 +0000
commit2b424cb5e181998de39cb87a5d6b7d4ca1d41676 (patch)
tree48442becfc4fb5e2d4317a75fde73929ea753909 /sys-apps/man-db
parentStabilization of r5 policies (and modules depending on it); some cleanup in s... (diff)
downloadgentoo-2-2b424cb5e181998de39cb87a5d6b7d4ca1d41676.tar.gz
gentoo-2-2b424cb5e181998de39cb87a5d6b7d4ca1d41676.tar.bz2
gentoo-2-2b424cb5e181998de39cb87a5d6b7d4ca1d41676.zip
Drop autotools-utils, fix up SRC_URI mirror, add USE=zlib, and touch up style.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog6
-rw-r--r--sys-apps/man-db/man-db-2.6.0.2.ebuild32
2 files changed, 19 insertions, 19 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 6ce4ab9038c7..a747ed5b6b4a 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.23 2011/07/09 16:41:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.24 2011/11/27 18:35:39 vapier Exp $
+
+ 27 Nov 2011; Mike Frysinger <vapier@gentoo.org> man-db-2.6.0.2.ebuild:
+ Drop autotools-utils, fix up SRC_URI mirror, add USE=zlib, and touch up
+ style.
09 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> man-db-2.6.0.2.ebuild:
Marked ~ppc64 wrt #371687
diff --git a/sys-apps/man-db/man-db-2.6.0.2.ebuild b/sys-apps/man-db/man-db-2.6.0.2.ebuild
index cb526905fd0c..07b00b75cfa0 100644
--- a/sys-apps/man-db/man-db-2.6.0.2.ebuild
+++ b/sys-apps/man-db/man-db-2.6.0.2.ebuild
@@ -1,55 +1,51 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.0.2.ebuild,v 1.8 2011/07/09 16:41:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.0.2.ebuild,v 1.9 2011/11/27 18:35:39 vapier Exp $
EAPI="2"
-inherit autotools-utils eutils
+inherit eutils
DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
HOMEPAGE="http://www.nongnu.org/man-db/"
-SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="berkdb +gdbm nls static-libs"
+IUSE="berkdb +gdbm nls static-libs zlib"
-RDEPEND="
- dev-libs/libpipeline
+RDEPEND="dev-libs/libpipeline
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!berkdb? ( !gdbm? ( sys-libs/gdbm ) )
|| ( sys-apps/groff >=app-doc/heirloom-doctools-080407-r2 )
- !sys-apps/man
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
enewgroup man 15
enewuser man 13 -1 /usr/share/man man
}
src_prepare() {
- # bug #371937
- epatch "${FILESDIR}"/${PN}-2.6.0.2-flock.h.patch
+ epatch "${FILESDIR}"/${PN}-2.6.0.2-flock.h.patch #371937
}
src_configure() {
- local db="gdbm"
- use berkdb && ! use gdbm && db="db"
+ export ac_cv_lib_z_gzopen=$(usex zlib)
econf \
--with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
$(use_enable nls) \
$(use_enable static-libs static) \
- --with-db=${db}
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
}
src_install() {
emake install DESTDIR="${D}" || die
dodoc README ChangeLog NEWS docs/{HACKING,TODO}
- use static-libs || remove_libtool_files
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
}