summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-17 14:51:07 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-17 14:51:07 +0000
commit2a0b5784f68bc3eb7a62b4d287c14035797df5ce (patch)
tree32803db8f522cc7aea515ea3cf892a1ee89c3d12 /sys-apps/man-db
parentVersion bump from Etoile 0.4.0 (diff)
downloadgentoo-2-2a0b5784f68bc3eb7a62b4d287c14035797df5ce.tar.gz
gentoo-2-2a0b5784f68bc3eb7a62b4d287c14035797df5ce.tar.bz2
gentoo-2-2a0b5784f68bc3eb7a62b4d287c14035797df5ce.zip
Version bump.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog7
-rw-r--r--sys-apps/man-db/man-db-2.5.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 5a86b2070d71..c19571a17c2f 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.5 2008/10/25 23:09:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.6 2008/11/17 14:51:07 vapier Exp $
+
+*man-db-2.5.3 (17 Nov 2008)
+
+ 17 Nov 2008; Mike Frysinger <vapier@gentoo.org> +man-db-2.5.3.ebuild:
+ Version bump.
*man-db-2.5.2 (25 Oct 2008)
diff --git a/sys-apps/man-db/man-db-2.5.3.ebuild b/sys-apps/man-db/man-db-2.5.3.ebuild
new file mode 100644
index 000000000000..24274b283a9d
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.5.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.5.3.ebuild,v 1.1 2008/11/17 14:51:07 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb gdbm nls"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_compile() {
+ local db="gdbm"
+ use berkdb && ! use gdbm && db="db"
+ econf \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ --with-db=${db} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc README docs/{ChangeLog,HACKING,NEWS,TODO}
+}