summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-06-23 22:25:59 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-06-23 22:25:59 +0000
commite2bab3d214cdbec7cbde07ba02ffa6ab7492c22f (patch)
tree374d0d2a40fec3eaf861c7b4782dfdf3959ece6d /sys-apps/lilo
parentMark stable on alpha (diff)
downloadgentoo-2-e2bab3d214cdbec7cbde07ba02ffa6ab7492c22f.tar.gz
gentoo-2-e2bab3d214cdbec7cbde07ba02ffa6ab7492c22f.tar.bz2
gentoo-2-e2bab3d214cdbec7cbde07ba02ffa6ab7492c22f.zip
New version.
Diffstat (limited to 'sys-apps/lilo')
-rw-r--r--sys-apps/lilo/ChangeLog7
-rw-r--r--sys-apps/lilo/Manifest6
-rw-r--r--sys-apps/lilo/files/digest-lilo-22.5.51
-rw-r--r--sys-apps/lilo/lilo-22.5.5.ebuild192
4 files changed, 203 insertions, 3 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index 2fcb611c6117..5d21656dc7af 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.21 2003/04/03 17:26:04 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.22 2003/06/23 22:25:18 azarah Exp $
+
+*lilo-22.5.5 (24 Jun 2003)
+
+ 24 Jun 2003; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.5.ebuild:
+ New version.
03 Apr 2003; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.1.ebuild :
Set OPTS down to -O1 to fix a problem where lilo sometimes locked at
diff --git a/sys-apps/lilo/Manifest b/sys-apps/lilo/Manifest
index 1087d7ca8591..0226b50de0f6 100644
--- a/sys-apps/lilo/Manifest
+++ b/sys-apps/lilo/Manifest
@@ -1,10 +1,12 @@
-MD5 02cc548f8f212d6f037eb9beccec294c ChangeLog 3226
+MD5 4727e891f3607aa414249bdb2c763092 ChangeLog 3342
MD5 d6daac26992f472c13439776f9262b58 lilo-22.1-r3.ebuild 1583
MD5 ce88b98514e48eeb2fc2005bd2e7c6f4 lilo-22.3.3-r1.ebuild 1999
MD5 a1121c6da464f7e187924173536e278c lilo-22.3.4.ebuild 1995
+MD5 53331ecc5c9b5e71517c144605c93d7d lilo-22.5.5.ebuild 4604
MD5 4612c953cf739cc77d9ea2ed52b09f2c lilo-22.5.1.ebuild 4519
MD5 00de3473e03e180faad32ed00335cc7b files/digest-lilo-22.1-r3 61
MD5 0a868ea4abd215e2181c6c756173b618 files/digest-lilo-22.3.3-r1 133
+MD5 ef895b0a61149eabd239f3e2b8419642 files/lilo.conf 908
MD5 93ff7a7535e7c8ff1327db52a3118bef files/digest-lilo-22.3.4 133
+MD5 f3c42e3a8ba9c0623ba4554ba22196ac files/digest-lilo-22.5.5 63
MD5 8e75fea24b47485fd4185b9962745117 files/digest-lilo-22.5.1 63
-MD5 ef895b0a61149eabd239f3e2b8419642 files/lilo.conf 908
diff --git a/sys-apps/lilo/files/digest-lilo-22.5.5 b/sys-apps/lilo/files/digest-lilo-22.5.5
new file mode 100644
index 000000000000..d82bbb75f590
--- /dev/null
+++ b/sys-apps/lilo/files/digest-lilo-22.5.5
@@ -0,0 +1 @@
+MD5 59d4aea879259085f0acd746fb2972bf lilo-22.5.5.tar.gz 405652
diff --git a/sys-apps/lilo/lilo-22.5.5.ebuild b/sys-apps/lilo/lilo-22.5.5.ebuild
new file mode 100644
index 000000000000..5734c0fe4e50
--- /dev/null
+++ b/sys-apps/lilo/lilo-22.5.5.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.5.ebuild,v 1.1 2003/06/23 22:25:18 azarah Exp $
+
+inherit mount-boot eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard Linux boot loader"
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${P}.tar.gz"
+# mirror://gentoo/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86"
+
+DEPEND="dev-lang/nasm
+ >=sys-devel/bin86-0.15.5"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${P}.tar.gz || die
+ cd ${S}
+
+ # Get all the loaders to install
+# cp Makefile Makefile.orig
+# sed -e 's:# $(BOOTS): $(BOOTS):' Makefile.orig > Makefile
+
+ # This bootlogo patch is borrowed from SuSE Linux.
+ # You should see Raphaël Quinet's (quinet@gamers.org) website,
+ # http://www.gamers.org/~quinet/lilo/index.html
+# epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+}
+
+src_compile() {
+ [ -z "${CC}" ] && CC="gcc"
+
+ emake CC="${CC}" OPT="-O1" \
+ lilo bootsect.b edit activate \
+ $(grep '^BOOTS' Makefile | sed -e 's:^BOOTS=::') || die
+}
+
+src_install() {
+ into /
+ dosbin lilo activate mkrescue
+ into /usr
+ dosbin keytab-lilo.pl
+
+ dodir /boot
+ insinto /boot
+ doins boot-text.b boot-menu.b boot-bmp.b chain.b mbr.b os2_d.b
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+}
+
+pkg_preinst() {
+ mount-boot_mount_boot_partition
+
+ if [ ! -L ${ROOT}/boot/boot.b -a -f ${ROOT}/boot/boot.b ]
+ then
+ einfo "Saving old boot.b..."
+ mv -f ${ROOT}/boot/boot.b ${ROOT}/boot/boot.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-text.b -a -f ${ROOT}/boot/boot-text.b ]
+ then
+ einfo "Saving old boot-text.b..."
+ mv -f ${ROOT}/boot/boot-text.b ${ROOT}/boot/boot-text.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-menu.b -a -f ${ROOT}/boot/boot-menu.b ]
+ then
+ einfo "Saving old boot-menu.b..."
+ mv -f ${ROOT}/boot/boot-menu.b ${ROOT}/boot/boot-menu.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-bmp.b -a -f ${ROOT}/boot/boot-bmp.b ]
+ then
+ einfo "Saving old boot-bmp.b..."
+ mv -f ${ROOT}/boot/boot-bmp.b ${ROOT}/boot/boot-bmp.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/chain.b -a -f ${ROOT}/boot/chain.b ]
+ then
+ einfo "Saving old chain.b..."
+ mv -f ${ROOT}/boot/chain.b ${ROOT}/boot/chain.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/mbr.b -a -f ${ROOT}/boot/mbr.b ]
+ then
+ einfo "Saving old mbr.b..."
+ mv -f ${ROOT}/boot/mbr.b ${ROOT}/boot/mbr.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/os2_d.b -a -f ${ROOT}/boot/os2_d.b ]
+ then
+ einfo "Saving old os2_d.b..."
+ mv -f ${ROOT}/boot/os2_d.b ${ROOT}/boot/os2_d.old
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ if lilocheck
+ then
+ einfo "Running LILO to complete the install ..."
+ /sbin/lilo &> /dev/null
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/lilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ sleep 5
+ fi
+ fi
+ echo
+ fi
+}
+