summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-01-25 01:50:06 +0000
committerDonny Davies <woodchip@gentoo.org>2003-01-25 01:50:06 +0000
commitd34092d0bec54c00e8a3f8360f3e4aeae1e64199 (patch)
tree36f3f0065d23dc02ae04d42602869ec408b0dac8 /sys-apps/lilo
parentmove mount /boot to pkg_preinst, remove the bells ;) (diff)
downloadgentoo-2-d34092d0bec54c00e8a3f8360f3e4aeae1e64199.tar.gz
gentoo-2-d34092d0bec54c00e8a3f8360f3e4aeae1e64199.tar.bz2
gentoo-2-d34092d0bec54c00e8a3f8360f3e4aeae1e64199.zip
move mount /boot to pkg_preinst
Diffstat (limited to 'sys-apps/lilo')
-rw-r--r--sys-apps/lilo/ChangeLog6
-rw-r--r--sys-apps/lilo/lilo-22.1-r3.ebuild10
-rw-r--r--sys-apps/lilo/lilo-22.3.3-r1.ebuild21
-rw-r--r--sys-apps/lilo/lilo-22.3.4.ebuild21
4 files changed, 25 insertions, 33 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index 5d52135b38d1..4fb10248c82a 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.16 2003/01/06 09:06:29 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.17 2003/01/25 01:50:03 woodchip Exp $
+
+ 24 Jan 2002; <woodchip@gentoo.org> *.ebuild : Reorder mount-boot.eclass
+ function, clean some fluff.
*lilo-22.3.4 (04 Jan 2002)
06 Jan 2002; Seemant Kulleen <seemant@gentoo.org> *.ebuild :
-
PROVIDE virtual/bootloader
04 Jan 2002; Donny Davies <woodchip@gentoo.org> :
diff --git a/sys-apps/lilo/lilo-22.1-r3.ebuild b/sys-apps/lilo/lilo-22.1-r3.ebuild
index fc014c2646b4..fa523fc0263f 100644
--- a/sys-apps/lilo/lilo-22.1-r3.ebuild
+++ b/sys-apps/lilo/lilo-22.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.1-r3.ebuild,v 1.15 2003/01/06 09:12:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.1-r3.ebuild,v 1.16 2003/01/25 01:50:03 woodchip Exp $
inherit mount-boot
@@ -43,6 +43,7 @@ src_install() {
}
pkg_preinst() {
+ mount-boot_mount_boot_partition
if [ ! -L $ROOT/boot/boot.b -a -f $ROOT/boot/boot.b ]
then
echo "Saving old boot.b..."
@@ -63,11 +64,6 @@ pkg_preinst() {
}
pkg_postinst() {
-
- . ${ROOT}/etc/init.d/functions.sh
-
einfo "Activating boot-menu..."
- ln -sf boot-menu.b $ROOT/boot/boot.b;
+ ln -sf boot-menu.b $ROOT/boot/boot.b
}
-
-
diff --git a/sys-apps/lilo/lilo-22.3.3-r1.ebuild b/sys-apps/lilo/lilo-22.3.3-r1.ebuild
index 6a23c50c12b3..1e9efa15e4be 100644
--- a/sys-apps/lilo/lilo-22.3.3-r1.ebuild
+++ b/sys-apps/lilo/lilo-22.3.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.3.3-r1.ebuild,v 1.6 2003/01/06 09:12:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.3.3-r1.ebuild,v 1.7 2003/01/25 01:50:03 woodchip Exp $
-inherit mount-boot
+inherit mount-boot eutils
S=${WORKDIR}/${P}
DESCRIPTION="Standard Linux boot loader"
@@ -11,7 +11,7 @@ SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${P}.tar.gz
HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
SLOT="0"
-LICENSE="BSD"
+LICENSE="BSD GPL-2"
KEYWORDS="x86 -ppc -sparc -alpha"
DEPEND="dev-lang/nasm
@@ -22,9 +22,10 @@ PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${P}.tar.gz || die
cd ${S} || die
- # groovy animated bootlogo patch, borrowed from suse and ported a bit
- # woodchip (sep 22 2002)
- bzip2 -dc ${DISTDIR}/${P}-gentoo.diff.bz2 | patch -p1 || die
+ # This bootlogo patch is borrowed from SuSE Linux.
+ # You should see Raphaël Quinet's (quinet@gamers.org) website,
+ # http://www.gamers.org/~quinet/lilo/index.html
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
}
src_compile() {
@@ -47,6 +48,7 @@ src_install() {
}
pkg_preinst() {
+ mount-boot_mount_boot_partition
if [ ! -L $ROOT/boot/boot.b -a -f $ROOT/boot/boot.b ]
then
einfo "Saving old boot.b..."
@@ -74,10 +76,5 @@ pkg_preinst() {
pkg_postinst() {
einfo "Activating boot-menu..."
- ln -snf boot-menu.b $ROOT/boot/boot.b
-
- einfo
- einfo "You can get some animations at:"
- einfo "http://www.gamers.org/~quinet/lilo/index.html"
- einfo
+ ln -sf boot-menu.b $ROOT/boot/boot.b
}
diff --git a/sys-apps/lilo/lilo-22.3.4.ebuild b/sys-apps/lilo/lilo-22.3.4.ebuild
index 3a602e4a58e1..e0c16ed5c840 100644
--- a/sys-apps/lilo/lilo-22.3.4.ebuild
+++ b/sys-apps/lilo/lilo-22.3.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.3.4.ebuild,v 1.3 2003/01/06 09:12:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.3.4.ebuild,v 1.4 2003/01/25 01:50:03 woodchip Exp $
-inherit mount-boot
+inherit mount-boot eutils
S=${WORKDIR}/${P}
DESCRIPTION="Standard Linux boot loader"
@@ -11,7 +11,7 @@ SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${P}.tar.gz
HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
SLOT="0"
-LICENSE="BSD"
+LICENSE="BSD GPL-2"
KEYWORDS="~x86 -ppc -sparc -alpha"
DEPEND="dev-lang/nasm
@@ -22,9 +22,10 @@ PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${P}.tar.gz || die
cd ${S} || die
- #Again, this is my go at SuSE's animated bootlogo patch.
- #lilo-22.3.4-gentoo.diff; <woodchip@gentoo.org> (03 Jan 2003)
- bzip2 -dc ${DISTDIR}/${P}-gentoo.diff.bz2 | patch -p1 || die
+ # This bootlogo patch is borrowed from SuSE Linux.
+ # You should see Raphaël Quinet's (quinet@gamers.org) website,
+ # http://www.gamers.org/~quinet/lilo/index.html
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
}
src_compile() {
@@ -47,6 +48,7 @@ src_install() {
}
pkg_preinst() {
+ mount-boot_mount_boot_partition
if [ ! -L $ROOT/boot/boot.b -a -f $ROOT/boot/boot.b ]
then
einfo "Saving old boot.b..."
@@ -74,10 +76,5 @@ pkg_preinst() {
pkg_postinst() {
einfo "Activating boot-menu..."
- ln -snf boot-menu.b $ROOT/boot/boot.b
-
- einfo
- einfo "You can get some animations at:"
- einfo "http://www.gamers.org/~quinet/lilo/index.html"
- einfo
+ ln -sf boot-menu.b $ROOT/boot/boot.b
}