summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-08-05 19:53:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-08-05 19:53:07 +0000
commit158ad835fa82683c4f3ae1cce6fab79e54250f63 (patch)
treefb6b6085b65111c523ce90172a6943bc9e9ca00b /sys-apps/lilo
parentAdd back lilo-22.5.1 ebuild that I removed by mistake. (diff)
downloadgentoo-2-158ad835fa82683c4f3ae1cce6fab79e54250f63.tar.gz
gentoo-2-158ad835fa82683c4f3ae1cce6fab79e54250f63.tar.bz2
gentoo-2-158ad835fa82683c4f3ae1cce6fab79e54250f63.zip
Add back lilo-22.5.1 ebuild that I removed by mistake.
Diffstat (limited to 'sys-apps/lilo')
-rw-r--r--sys-apps/lilo/ChangeLog7
-rw-r--r--sys-apps/lilo/Manifest4
-rw-r--r--sys-apps/lilo/files/digest-lilo-22.5.11
-rw-r--r--sys-apps/lilo/lilo-22.5.1.ebuild190
4 files changed, 199 insertions, 3 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index f3b701b06d1b..b80a085aeeaf 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.30 2003/08/03 21:02:20 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.31 2003/08/05 19:52:09 azarah Exp $
+
+*lilo-22.5.1 (05 Aug 2003)
+
+ 05 Aug 2003; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.1.ebuild:
+ Add back lilo-22.5.1 ebuild that I removed by mistake.
03 Aug 2003; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.6-r3.ebuild,
files/lilo-22.5.6-animated-menu.patch, files/lilo-22.5.6-glibc233.patch:
diff --git a/sys-apps/lilo/Manifest b/sys-apps/lilo/Manifest
index fafe829f841b..732a39298a8b 100644
--- a/sys-apps/lilo/Manifest
+++ b/sys-apps/lilo/Manifest
@@ -1,8 +1,8 @@
-MD5 ff34268d6e17191d1d12f75973f9e15d ChangeLog 5219
+MD5 16de85795a164416d7b783c42e54c4b3 ChangeLog 5377
MD5 a0c025ab9651ddaf0f1dc593a48df94a lilo-22.1-r3.ebuild 1582
MD5 9d48349e4847a7aa2a6824848c57e8f2 lilo-22.3.3-r1.ebuild 1998
MD5 7dd6ff54cf104acb2bf33b4c22b85460 lilo-22.3.4.ebuild 2003
-MD5 36f09270c28831f5de03b2fc5ff35234 lilo-22.5.1.ebuild 4545
+MD5 1a1174afd8e5eb548f8370206ff91e8b lilo-22.5.1.ebuild 4523
MD5 01bd0c419e2f78240949543992494dc8 lilo-22.5.6-r2.ebuild 3540
MD5 f9f89e2d601b6c9f6acb95ce00759c78 lilo-22.5.6-r3.ebuild 3826
MD5 00de3473e03e180faad32ed00335cc7b files/digest-lilo-22.1-r3 61
diff --git a/sys-apps/lilo/files/digest-lilo-22.5.1 b/sys-apps/lilo/files/digest-lilo-22.5.1
new file mode 100644
index 000000000000..6bca071889e6
--- /dev/null
+++ b/sys-apps/lilo/files/digest-lilo-22.5.1
@@ -0,0 +1 @@
+MD5 246415f158a3f6d5a00f8882c217b600 lilo-22.5.1.tar.gz 382497
diff --git a/sys-apps/lilo/lilo-22.5.1.ebuild b/sys-apps/lilo/lilo-22.5.1.ebuild
new file mode 100644
index 000000000000..5bae9ba14d85
--- /dev/null
+++ b/sys-apps/lilo/lilo-22.5.1.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.1.ebuild,v 1.9 2003/08/05 19:52:09 azarah Exp $
+
+inherit mount-boot eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard Linux boot loader"
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/obsolete/${P}.tar.gz"
+# mirror://gentoo/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* x86"
+
+DEPEND="dev-lang/nasm
+ >=sys-devel/bin86-0.15.5"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${P}.tar.gz || die
+ cd ${S}
+
+ # Get all the loaders to install
+ cp Makefile Makefile.orig
+ sed -e 's:# $(BOOTS): $(BOOTS):' Makefile.orig > Makefile
+
+ # This bootlogo patch is borrowed from SuSE Linux.
+ # You should see Raphaël Quinet's (quinet@gamers.org) website,
+ # http://www.gamers.org/~quinet/lilo/index.html
+# epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+}
+
+src_compile() {
+ [ -z "${CC}" ] && CC="gcc"
+
+ emake CC="${CC}" OPT="-O1" || die
+}
+
+src_install() {
+ into /
+ dosbin lilo activate mkrescue
+ into /usr
+ dosbin keytab-lilo.pl
+
+ dodir /boot
+ insinto /boot
+ doins boot-text.b boot-menu.b boot-bmp.b chain.b mbr.b os2_d.b
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+}
+
+pkg_preinst() {
+ mount-boot_mount_boot_partition
+
+ if [ ! -L ${ROOT}/boot/boot.b -a -f ${ROOT}/boot/boot.b ]
+ then
+ einfo "Saving old boot.b..."
+ mv -f ${ROOT}/boot/boot.b ${ROOT}/boot/boot.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-text.b -a -f ${ROOT}/boot/boot-text.b ]
+ then
+ einfo "Saving old boot-text.b..."
+ mv -f ${ROOT}/boot/boot-text.b ${ROOT}/boot/boot-text.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-menu.b -a -f ${ROOT}/boot/boot-menu.b ]
+ then
+ einfo "Saving old boot-menu.b..."
+ mv -f ${ROOT}/boot/boot-menu.b ${ROOT}/boot/boot-menu.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-bmp.b -a -f ${ROOT}/boot/boot-bmp.b ]
+ then
+ einfo "Saving old boot-bmp.b..."
+ mv -f ${ROOT}/boot/boot-bmp.b ${ROOT}/boot/boot-bmp.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/chain.b -a -f ${ROOT}/boot/chain.b ]
+ then
+ einfo "Saving old chain.b..."
+ mv -f ${ROOT}/boot/chain.b ${ROOT}/boot/chain.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/mbr.b -a -f ${ROOT}/boot/mbr.b ]
+ then
+ einfo "Saving old mbr.b..."
+ mv -f ${ROOT}/boot/mbr.b ${ROOT}/boot/mbr.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/os2_d.b -a -f ${ROOT}/boot/os2_d.b ]
+ then
+ einfo "Saving old os2_d.b..."
+ mv -f ${ROOT}/boot/os2_d.b ${ROOT}/boot/os2_d.old
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ if lilocheck
+ then
+ einfo "Running LILO to complete the install ..."
+ /sbin/lilo &> /dev/null
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/lilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ sleep 5
+ fi
+ fi
+ echo
+ fi
+}
+