summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-17 09:18:15 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-17 09:18:15 +0000
commitd31f02734e95783a3d0d803c27070560e78cbe5f (patch)
treeb851e6654844a35d90ed05bc6f3bbd5177d3c652 /sys-apps/less
parentVersion bump. (diff)
downloadgentoo-2-d31f02734e95783a3d0d803c27070560e78cbe5f.tar.gz
gentoo-2-d31f02734e95783a3d0d803c27070560e78cbe5f.tar.bz2
gentoo-2-d31f02734e95783a3d0d803c27070560e78cbe5f.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/ChangeLog7
-rw-r--r--sys-apps/less/less-462.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/less/ChangeLog b/sys-apps/less/ChangeLog
index 43e3ac7aea36..2a55ab42de5c 100644
--- a/sys-apps/less/ChangeLog
+++ b/sys-apps/less/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/less
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/ChangeLog,v 1.178 2013/09/05 09:51:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/ChangeLog,v 1.179 2013/12/17 09:18:15 radhermit Exp $
+
+*less-462 (17 Dec 2013)
+
+ 17 Dec 2013; Tim Harder <radhermit@gentoo.org> +less-462.ebuild:
+ Version bump.
05 Sep 2013; Mike Frysinger <vapier@gentoo.org> less-457.ebuild:
Mark m68k stable #450608.
diff --git a/sys-apps/less/less-462.ebuild b/sys-apps/less/less-462.ebuild
new file mode 100644
index 000000000000..5ecbede2e7dc
--- /dev/null
+++ b/sys-apps/less/less-462.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/less/less-462.ebuild,v 1.1 2013/12/17 09:18:15 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+CODE2COLOR_PV="0.2"
+CODE2COLOR_P="code2color-${CODE2COLOR_PV}"
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz
+ http://www-zeuthen.desy.de/~friebel/unix/less/code2color -> ${CODE2COLOR_P}"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cp "${DISTDIR}"/${CODE2COLOR_P} "${S}"/code2color || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${CODE2COLOR_P}.patch
+}
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ econf \
+ --with-regex=$(usex pcre pcre posix) \
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+}
+
+src_install() {
+ default
+
+ dobin code2color
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ dosym lesspipe /usr/bin/lesspipe.sh
+ newenvd "${FILESDIR}"/less.envd 70less
+
+ dodoc "${FILESDIR}"/README.Gentoo
+}
+
+pkg_postinst() {
+ elog "lesspipe offers colorization options. Run 'lesspipe -h' for info."
+}