summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2014-08-29 18:35:57 +0000
committerRichard Yao <ryao@gentoo.org>2014-08-29 18:35:57 +0000
commitd413a96db3218399635d0e1cc1869d530df175e5 (patch)
tree135e47c796e810f36b4a9f84007a6c92e683f844 /sys-apps/kmod/kmod-18.ebuild
parentversion bump (diff)
downloadgentoo-2-d413a96db3218399635d0e1cc1869d530df175e5.tar.gz
gentoo-2-d413a96db3218399635d0e1cc1869d530df175e5.tar.bz2
gentoo-2-d413a96db3218399635d0e1cc1869d530df175e5.zip
Use ${EROOT} instead of / or ${ROOT}. This lets things build on Gentoo Prefix and should allow cross compilation with Catalyst. WilliamH gave his okay in IRC for the non-maintainer commit.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'sys-apps/kmod/kmod-18.ebuild')
-rw-r--r--sys-apps/kmod/kmod-18.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-apps/kmod/kmod-18.ebuild b/sys-apps/kmod/kmod-18.ebuild
index 86ce8f0800ad..29c80864bad2 100644
--- a/sys-apps/kmod/kmod-18.ebuild
+++ b/sys-apps/kmod/kmod-18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-18.ebuild,v 1.1 2014/06/22 08:01:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-18.ebuild,v 1.2 2014/08/29 18:35:57 ryao Exp $
EAPI=5
@@ -74,8 +74,8 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --bindir=/bin
- --with-rootlibdir="/$(get_libdir)"
+ --bindir="${EROOT}bin"
+ --with-rootlibdir="${EROOT}$(get_libdir)"
--enable-shared
$(use_enable static-libs static)
$(use_enable tools)
@@ -168,23 +168,23 @@ src_install() {
}
pkg_postinst() {
- if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
+ if [[ -L ${EROOT%/}/etc/runlevels/boot/static-nodes ]]; then
ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
- rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
+ rm -f "${EROOT%/}"/etc/runlevels/boot/static-nodes
fi
# Add kmod to the runlevel automatically if this is the first install of this package.
if [[ -z ${REPLACING_VERSIONS} ]]; then
- if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
- mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
+ if [[ ! -d ${EROOT%/}/etc/runlevels/sysinit ]]; then
+ mkdir -p "${EROOT%/}"/etc/runlevels/sysinit
fi
- if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
- ln -s /etc/init.d/kmod-static-nodes "${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
+ if [[ -x ${EROOT%/}/etc/init.d/kmod-static-nodes ]]; then
+ ln -s /etc/init.d/kmod-static-nodes "${EROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
fi
fi
- if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
- if [[ ! -e ${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
+ if [[ -e ${EROOT%/}/etc/runlevels/sysinit ]]; then
+ if [[ ! -e ${EROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
ewarn
ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
ewarn "kernel modules to have required static nodes!"