summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-05 05:15:32 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-05 05:15:32 +0000
commit4feb98f8e929731f1b8cfed1e701a29cbc8c4c4b (patch)
tree11862d956ef626061aa92272ee2ca57f7812e059 /sys-apps/irqbalance
parentRemove old. (diff)
downloadgentoo-2-4feb98f8e929731f1b8cfed1e701a29cbc8c4c4b.tar.gz
gentoo-2-4feb98f8e929731f1b8cfed1e701a29cbc8c4c4b.tar.bz2
gentoo-2-4feb98f8e929731f1b8cfed1e701a29cbc8c4c4b.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/irqbalance')
-rw-r--r--sys-apps/irqbalance/ChangeLog7
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.4.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-apps/irqbalance/ChangeLog b/sys-apps/irqbalance/ChangeLog
index 20d91432f69e..5acf2dcf50f8 100644
--- a/sys-apps/irqbalance/ChangeLog
+++ b/sys-apps/irqbalance/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/irqbalance
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.43 2012/08/14 10:36:47 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/ChangeLog,v 1.44 2012/09/05 05:15:32 radhermit Exp $
+
+*irqbalance-1.0.4 (05 Sep 2012)
+
+ 05 Sep 2012; Tim Harder <radhermit@gentoo.org> +irqbalance-1.0.4.ebuild:
+ Version bump.
14 Aug 2012; Johannes Huber <johu@gentoo.org> irqbalance-1.0.3.ebuild:
Stable for x86, wrt bug #422177
diff --git a/sys-apps/irqbalance/irqbalance-1.0.4.ebuild b/sys-apps/irqbalance/irqbalance-1.0.4.ebuild
new file mode 100644
index 000000000000..774bc35ebbf5
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.4.ebuild,v 1.1 2012/09/05 05:15:32 radhermit Exp $
+
+EAPI=4
+
+inherit systemd
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="http://irqbalance.googlecode.com/"
+SRC_URI="http://irqbalance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps numa"
+
+RDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with caps libcap-ng) \
+ $(use_enable numa)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/irqbalance.init.2 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit "${FILESDIR}"/irqbalance.service
+}