summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-02-15 18:35:54 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-02-15 18:35:54 +0000
commit244ebb4d858becf6633bd515476f037ffd9af92c (patch)
tree13a92b90333af04f68bf40ceacd58a4e9ce09055 /sys-apps/i2c/i2c-2.10.0.ebuild
parentUpdate cache barriers patch used for IP28 mips systems. Also include a modifi... (diff)
downloadgentoo-2-244ebb4d858becf6633bd515476f037ffd9af92c.tar.gz
gentoo-2-244ebb4d858becf6633bd515476f037ffd9af92c.tar.bz2
gentoo-2-244ebb4d858becf6633bd515476f037ffd9af92c.zip
Version bump.
(Portage version: 2.0.54)
Diffstat (limited to 'sys-apps/i2c/i2c-2.10.0.ebuild')
-rw-r--r--sys-apps/i2c/i2c-2.10.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/i2c/i2c-2.10.0.ebuild b/sys-apps/i2c/i2c-2.10.0.ebuild
new file mode 100644
index 000000000000..9933c04e2eed
--- /dev/null
+++ b/sys-apps/i2c/i2c-2.10.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.10.0.ebuild,v 1.1 2006/02/15 18:33:39 brix Exp $
+
+inherit eutils toolchain-funcs linux-info
+
+DESCRIPTION="I2C Bus kernel modules for linux-2.4.x"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-amd64 -ppc ~x86"
+
+IUSE=""
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 4 10; then
+ eerror "${P} requires kernel 2.4.10 or later"
+ die "${P} requires kernel 2.4.10 or later"
+ fi
+
+ if kernel_is gt 2 4; then
+ eerror "${P} is only needed for kernel 2.4.x"
+ eerror "You need to use the in-kernel I2C drivers for later kernels."
+ die "Non 2.4.x kernel detected"
+ fi
+
+ if linux_chkconfig_present I2C; then
+ eerror "${P} requires kernel CONFIG_I2C to be disabled."
+ die "Kernel with CONFIG_I2C detected"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-module-path.patch
+}
+
+src_compile () {
+ einfo
+ einfo "You may safely ignore any errors from compilation"
+ einfo "that contain \"No such file or directory\" references."
+ einfo
+
+ emake CC=$(tc-getCC) LINUX=${KV_DIR} || die "emake failed"
+}
+
+src_install() {
+ einfo
+ einfo "This package will need to overwrite your kernel I2C headers."
+ einfo "If this fails, please emerge with FEATURES=\"-collision-protect\""
+ einfo
+ ebeep 5
+
+ emake CC=$(tc-getCC) \
+ LINUX=${KV_DIR} LINUX_INCLUDE_DIR=${KV_DIR}/include/linux MODPREF=/lib/modules/${KV_FULL} \
+ DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install \
+ || die "emake install failed"
+
+ dodoc CHANGES README TODO
+
+ dodoc doc/*
+}