summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-12-16 22:42:37 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-12-16 22:42:37 +0000
commit172be84766a3dc615640c7387cd29f9f35ba23eb (patch)
tree210314ea8d9c827728d893423bf101c2dd76d971 /sys-apps/hwloc
parentversion bump (diff)
downloadgentoo-2-172be84766a3dc615640c7387cd29f9f35ba23eb.tar.gz
gentoo-2-172be84766a3dc615640c7387cd29f9f35ba23eb.tar.bz2
gentoo-2-172be84766a3dc615640c7387cd29f9f35ba23eb.zip
Version bump, add USE static-libs, migrate to autotools-utils.eclass
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/hwloc-1.0.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 6a44dce499be..5120aefee241 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.3 2010/11/27 18:47:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.4 2010/12/16 22:42:37 xarthisius Exp $
+
+*hwloc-1.0.3 (16 Dec 2010)
+
+ 16 Dec 2010; Kacper Kowalik <xarthisius@gentoo.org> +hwloc-1.0.3.ebuild:
+ Version bump, add USE static-libs, migrate to autotools-utils.eclass
27 Nov 2010; Raúl Porcel <armin76@gentoo.org> hwloc-1.0.2.ebuild:
Add ~alpha/~ia64/~sparc wrt #345231
diff --git a/sys-apps/hwloc/hwloc-1.0.3.ebuild b/sys-apps/hwloc/hwloc-1.0.3.ebuild
new file mode 100644
index 000000000000..24ca0284eeaf
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.0.3.ebuild,v 1.1 2010/12/16 22:42:37 xarthisius Exp $
+
+EAPI=2
+
+inherit autotools-utils
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/hwloc/v1.0/downloads/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="cairo svg static-libs xml X"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable cairo)
+ $(use_enable static-libs static)
+ $(use_enable xml)
+ $(use_with X x)
+ --disable-silent-rules
+ )
+ autotools-utils_src_configure
+}