summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-01 01:46:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-01 01:46:52 +0000
commit6463b6f91ec92c2030d6fa310d6eaad42faeac59 (patch)
tree2e72d73eba53d4366a6334611b0791114844b6ce /sys-apps/hwids/hwids-99999999.ebuild
parentAdd runtime dependency on setuptools. (diff)
downloadgentoo-2-6463b6f91ec92c2030d6fa310d6eaad42faeac59.tar.gz
gentoo-2-6463b6f91ec92c2030d6fa310d6eaad42faeac59.tar.bz2
gentoo-2-6463b6f91ec92c2030d6fa310d6eaad42faeac59.zip
Initial import of a split ebuild for USB/PCI ids.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwids/hwids-99999999.ebuild')
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
new file mode 100644
index 000000000000..3b8e61b88d83
--- /dev/null
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.1 2012/04/01 01:46:52 flameeyes Exp $
+
+EAPI="4"
+
+DESCRIPTION="Hardware (PCI, USB) IDs databases"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/hwids.git;a=summary"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="net-misc/wget"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+src_compile() {
+ wget http://pci-ids.ucw.cz/v2.2/pci.ids.gz http://www.linux-usb.org/usb.ids.gz || die
+
+ for file in {usb,pci}.ids; do
+ zcat ${file}.gz > ${file} || die
+ done
+}
+
+src_install() {
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz}
+}