summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-03-19 05:40:46 +0000
committerZack Welch <zwelch@gentoo.org>2003-03-19 05:40:46 +0000
commit85dad47536b861e1f07df53dc4f6b4df26b841f2 (patch)
tree1026a23fd427ec4174f7eff8b4fd9e0f49a0bf42 /sys-apps/hotplug
parentbump of unstable (diff)
downloadgentoo-2-85dad47536b861e1f07df53dc4f6b4df26b841f2.tar.gz
gentoo-2-85dad47536b861e1f07df53dc4f6b4df26b841f2.tar.bz2
gentoo-2-85dad47536b861e1f07df53dc4f6b4df26b841f2.zip
fix bug 17799 in hotplug
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/ChangeLog7
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20020826-r13
-rw-r--r--sys-apps/hotplug/hotplug-20020826-r1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 0b8c564835a3..cbfc84ac1de6 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.11 2003/03/19 04:35:48 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.12 2003/03/19 05:40:46 zwelch Exp $
+
+*hotplug-20020826-r1 (18 Mar 2003)
+
+ 18 Mar 2003; Zach Welch <zwelch@gentoo.org> hotplug-20020826-r1.ebuild:
+ fix bug 17799
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/sys-apps/hotplug/files/digest-hotplug-20020826-r1 b/sys-apps/hotplug/files/digest-hotplug-20020826-r1
new file mode 100644
index 000000000000..f688d2cecefa
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20020826-r1
@@ -0,0 +1,3 @@
+MD5 eb3e3aacfe072e7bd31a4e01fd8af2e0 hotplug-2002_08_26.tar.gz 37805
+MD5 4f993af8adc6c016fd8efabf9fd41f4c hotplug-gentoo-conf.tar.bz2 4255
+MD5 9db8567ab6ae2a5d297eca8ab1ab2960 hotplug-20020826-gentoo-patches.tar.bz2 2792
diff --git a/sys-apps/hotplug/hotplug-20020826-r1.ebuild b/sys-apps/hotplug/hotplug-20020826-r1.ebuild
new file mode 100644
index 000000000000..746aded9c3ce
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20020826-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020826-r1.ebuild,v 1.1 2003/03/19 05:40:46 zwelch Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-gentoo-conf.tar.bz2
+ mirror://gentoo/${P}-gentoo-patches.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/etc/hotplug
+ epatch ${WORKDIR}/hotplug-patches/
+
+ # fix for bug 17799
+ sed -i -e '145s:-le:-lt:' ${S}/etc/hotplug/usb.rc
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+
+ exeinto /etc/init.d
+ newexe ${WORKDIR}/hotplug-conf/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${WORKDIR}/hotplug-conf/usb.conf usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}