summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-11 04:32:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-11 04:32:37 +0000
commit9373c01f91791a3a1b9e2075a3a31a2a853b9bdf (patch)
tree3959e7ce53319341d677b87a599e5e7a89ac9d73 /sys-apps/help2man
parentMark/ia64/s390/sh/#296432. stable (diff)
downloadgentoo-2-9373c01f91791a3a1b9e2075a3a31a2a853b9bdf.tar.gz
gentoo-2-9373c01f91791a3a1b9e2075a3a31a2a853b9bdf.tar.bz2
gentoo-2-9373c01f91791a3a1b9e2075a3a31a2a853b9bdf.zip
Version bump #300543 by Jeroen Roovers.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/ChangeLog7
-rw-r--r--sys-apps/help2man/help2man-1.37.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index d42134bdcae8..5f6c5ffd4db1 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/help2man
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.41 2010/01/01 15:23:58 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.42 2010/01/11 04:32:37 vapier Exp $
+
+*help2man-1.37.1 (11 Jan 2010)
+
+ 11 Jan 2010; Mike Frysinger <vapier@gentoo.org> +help2man-1.37.1.ebuild:
+ Version bump #300543 by Jeroen Roovers.
01 Jan 2010; Tobias Klausmann <klausman@gentoo.org>
help2man-1.36.4-r1.ebuild:
diff --git a/sys-apps/help2man/help2man-1.37.1.ebuild b/sys-apps/help2man/help2man-1.37.1.ebuild
new file mode 100644
index 000000000000..a8b3579f83fa
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.37.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.37.1.ebuild,v 1.1 2010/01/11 04:32:37 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man"
+SRC_URI="mirror://gnu/help2man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls elibc_glibc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( nls? ( dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1 ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.36.4-respect-LDFLAGS.patch
+}
+
+src_compile() {
+ local myconf
+ use elibc_glibc && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog NEWS README THANKS
+}