summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-04-17 19:02:48 +0000
committerMarinus Schraal <foser@gentoo.org>2005-04-17 19:02:48 +0000
commitc103d3750e4febc6132278e63f64548f1496533d (patch)
tree28f63e7cb37e5d4e8a2f0080fdd58b6579caa596 /sys-apps/hal
parentRemoved obsolete versions. (diff)
downloadgentoo-2-c103d3750e4febc6132278e63f64548f1496533d.tar.gz
gentoo-2-c103d3750e4febc6132278e63f64548f1496533d.tar.bz2
gentoo-2-c103d3750e4febc6132278e63f64548f1496533d.zip
a few fixes
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-apps/hal')
-rw-r--r--sys-apps/hal/ChangeLog9
-rw-r--r--sys-apps/hal/files/digest-hal-0.4.7-r21
-rw-r--r--sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch12
-rw-r--r--sys-apps/hal/files/hal-0.4.7-vfat_mount_utf8.patch12
-rw-r--r--sys-apps/hal/hal-0.4.7-r2.ebuild134
5 files changed, 167 insertions, 1 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 810ca49a99a6..df0250354c1f 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.33 2005/04/09 12:59:48 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.34 2005/04/17 19:02:48 foser Exp $
+
+*hal-0.4.7-r2 (17 Apr 2005)
+
+ 17 Apr 2005; foser <foser@gentoo.org> hal-0.4.7-r2.ebuild :
+ Fix floppy detection with newer kernels
+ Change policy on mounting removable drives (#83025)
+ Keepdir some policy dirs (#87167)
09 Apr 2005; Markus Rothe <corsair@gentoo.org> hal-0.4.5-r2.ebuild:
Stable on ppc64
diff --git a/sys-apps/hal/files/digest-hal-0.4.7-r2 b/sys-apps/hal/files/digest-hal-0.4.7-r2
new file mode 100644
index 000000000000..031b4dff3230
--- /dev/null
+++ b/sys-apps/hal/files/digest-hal-0.4.7-r2
@@ -0,0 +1 @@
+MD5 3386817a6811cce803bcfa8a20b05c51 hal-0.4.7.tar.gz 1349064
diff --git a/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch b/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch
new file mode 100644
index 000000000000..b04168bf01c0
--- /dev/null
+++ b/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch
@@ -0,0 +1,12 @@
+diff -x '*~' -uNr hal-0.4.7/hald/linux/platform_bus_device.c hal-0.4.7.patched/hald/linux/platform_bus_device.c
+--- hal-0.4.7/hald/linux/platform_bus_device.c 2004-11-22 22:53:50.000000000 +0100
++++ hal-0.4.7.patched/hald/linux/platform_bus_device.c 2005-04-17 19:20:37.000000000 +0200
+@@ -66,7 +66,7 @@
+ if (strncmp (device->bus_id, "floppy", 6) != 0)
+ return FALSE;
+
+- sscanf (device->bus_id, "floppy%d", &number);
++ sscanf (device->bus_id, "%*[flopy.]%d", &number);
+
+ /* get device file */
+ snprintf (fd_sysfs_path, sizeof (fd_sysfs_path), "%s/block/fd%d",
diff --git a/sys-apps/hal/files/hal-0.4.7-vfat_mount_utf8.patch b/sys-apps/hal/files/hal-0.4.7-vfat_mount_utf8.patch
new file mode 100644
index 000000000000..0c973e3d6a64
--- /dev/null
+++ b/sys-apps/hal/files/hal-0.4.7-vfat_mount_utf8.patch
@@ -0,0 +1,12 @@
+diff -uNr hal-0.4.7/fdi/90defaultpolicy/storage-policy.fdi hal-0.4.7.patched/fdi/90defaultpolicy/storage-policy.fdi
+--- hal-0.4.7/fdi/90defaultpolicy/storage-policy.fdi 2005-01-20 18:03:57.000000000 +0100
++++ hal-0.4.7.patched/fdi/90defaultpolicy/storage-policy.fdi 2005-04-17 20:40:57.000000000 +0200
+@@ -166,7 +166,7 @@
+
+ <!-- Use UTF-8 charset for vfat -->
+ <match key="volume.fstype" string="vfat">
+- <merge key="volume.policy.mount_option.iocharset=utf8" type="bool">true</merge>
++ <merge key="volume.policy.mount_option.utf8" type="bool">true</merge>
+ </match>
+
+ <!-- whitelist of partition table id's, if from a msdos partition table -->
diff --git a/sys-apps/hal/hal-0.4.7-r2.ebuild b/sys-apps/hal/hal-0.4.7-r2.ebuild
new file mode 100644
index 000000000000..71ca57a2cb7d
--- /dev/null
+++ b/sys-apps/hal/hal-0.4.7-r2.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.7-r2.ebuild,v 1.1 2005/04/17 19:02:48 foser Exp $
+
+inherit eutils python linux-info versionator flag-o-matic
+
+DESCRIPTION="Hardware Abstraction Layer"
+HOMEPAGE="http://www.freedesktop.org/Software/hal"
+SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.0 )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~ppc64"
+IUSE="debug pcmcia doc"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=sys-apps/dbus-0.22-r1
+ dev-libs/expat
+ sys-fs/udev
+ sys-apps/hotplug
+ sys-libs/libcap
+ dev-libs/popt
+ >=sys-apps/util-linux-2.12i
+ || ( >=sys-kernel/linux-headers-2.6 sys-kernel/linux26-headers )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ doc? ( app-doc/doxygen )"
+# dep on a specific util-linux version for
+# managed mount patches #70873
+
+# We need to run at least a 2.6.10 kernel, this is a
+# way to ensure that to some extent
+pkg_setup() {
+
+ if get_version; then
+ kernel_is ge 2 6 10 && break
+ else
+ RKV=$(uname -r)
+ RKV=${RKV//-*}
+ if version_is_at_least "2.6.10" ${RKV}; then
+ break
+ fi
+ fi
+ die "You need a 2.6.10 or newer kernel to build this pack"
+
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # remove pamconsole option
+ epatch ${FILESDIR}/${PN}-0.4.1-old_storage_policy.patch
+ # pick up the gentoo usermap
+ epatch ${FILESDIR}/${PN}-0.4.5-gentoo_gphoto2_usermap.patch
+ # don't doubleadd devices
+ epatch ${FILESDIR}/${P}-dont_add_device_twice-r1.patch
+ # fix memleaks
+ cd ${S}/hald
+ epatch ${FILESDIR}/${P}-device_info_leak.patch
+ # detect floppy drives on >=2.6.12 kernels as well
+ epatch ${FILESDIR}/${P}-sys_floppy_detection.patch
+ # set defaultpolicy for vfat from iocharset=utf8 to utf8 (#83025)
+ cd ${S}
+ epatch ${FILESDIR}/${P}-vfat_mount_utf8.patch
+
+}
+
+src_compile() {
+
+ # FIXME : docs
+ econf \
+ `use_enable debug verbose-mode` \
+ `use_enable pcmcia pcmcia-support` \
+ --enable-sysfs-carrier \
+ --enable-fstab-sync \
+ --enable-hotplug-map \
+ --disable-docbook-docs \
+ `use_enable doc doxygen-docs` \
+ --with-pid-file=/var/run/hald/hald.pid \
+ || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # We install this in a seperate package to avoid gnome-python dep
+ rm ${D}/usr/bin/hal-device-manager
+
+ # initscript
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/hald
+
+ # place our pid file
+ keepdir /var/run/hald
+
+ # keep the policy setup intact
+ keepdir /usr/share/hal/fdi/{95userpolicy,50user,40oem,30osvendor,10generic}
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+}
+
+pkg_preinst() {
+
+ enewgroup haldaemon || die "Problem adding haldaemon group"
+ enewuser haldaemon -1 /bin/false /dev/null haldaemon || die "Problem adding haldaemon user"
+
+}
+
+pkg_postinst() {
+
+ # make sure the permissions on the pid dir are alright & after preinst
+ chown haldaemon:haldaemon /var/run/hald
+
+ ewarn "Enabled in this ebuild by default is the usage of fstab-sync"
+ ewarn "that will create mount rules for non-existing devices in"
+ ewarn "fstab if needed, mount points will be created in /media."
+ ewarn "This functionality alters /etc/fstab runtime on the filesystem"
+ ewarn "and should be considered a security risk."
+ echo
+ einfo "The HAL daemon needs to be running for certain applications to"
+ einfo "work. Suggested is to add the init script to your start-up"
+ einfo "scripts, this should be done like this :"
+ einfo "\`rc-update add hald default\`"
+
+}