summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-27 03:47:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-27 03:47:17 +0000
commit54c349033fb9ef5965aa15783539bd4ccf07fab6 (patch)
treee5c9f48c11b54c1699d6529160b63475f3a0e2a0 /sys-apps/groff
parentold (diff)
downloadgentoo-2-54c349033fb9ef5965aa15783539bd4ccf07fab6.tar.gz
gentoo-2-54c349033fb9ef5965aa15783539bd4ccf07fab6.tar.bz2
gentoo-2-54c349033fb9ef5965aa15783539bd4ccf07fab6.zip
Update the netpbm to work with shells that suck (like on SunOS) #89174.
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog8
-rw-r--r--sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch27
-rw-r--r--sys-apps/groff/groff-1.19.1-r2.ebuild3
3 files changed, 30 insertions, 8 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index d55794c8ffcd..70c67b0afa1d 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/groff
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.56 2005/01/02 23:19:04 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.57 2005/04/27 03:47:17 vapier Exp $
+
+ 27 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ files/groff-1.18-no-netpbm-depend.patch, groff-1.19.1-r2.ebuild:
+ Update the netpbm to work with shells that suck (like on SunOS) #89174.
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch b/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch
index 5a6817e614e4..1ec42fce9616 100644
--- a/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch
+++ b/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch
@@ -1,19 +1,36 @@
+Don't install the example files. The second hunk is to workaround
+shells that suck at life.
+
+http://bugs.gentoo.org/show_bug.cgi?id=89174
+
--- groff-1.18/doc/Makefile.sub
+++ groff-1.18/doc/Makefile.sub
-@@ -60,12 +60,14 @@
+@@ -60,12 +60,12 @@
HTMLDOCIMAGEFILES=\
pic*
-EXAMPLEFILES=\
-+EXAMPLEFILES=
-+EXAMPLEFILES_IGNORE=\
++EXAMPLEFILES=#\
webpage.ms \
grnexmpl.g \
grnexmpl.me
-PROCESSEDEXAMPLEFILES=\
-+PROCESSEDEXAMPLEFILES=
-+PROCESSEDEXAMPLEFILES_IGNORE=\
++PROCESSEDEXAMPLEFILES=#\
webpage.ps \
gnu.eps \
gnu.png \
+@@ -170,11 +170,11 @@
+ $(INSTALL_DATA) $$f $(docdir)/$$f; \
+ done
+ -test -d $(exampledir) || $(mkinstalldirs) $(exampledir)
+- for f in $(EXAMPLEFILES); do \
++ list="$(EXAMPLEFILES)"; for f in $${list}; do \
+ rm -f $(exampledir)/$$f; \
+ $(INSTALL_DATA) $(srcdir)/$$f $(exampledir)/$$f; \
+ done
+- for f in $(PROCESSEDEXAMPLEFILES); do \
++ list="$(PROCESSEDEXAMPLEFILES)"; for f in $${list}; do \
+ rm -f $(exampledir)/$$f; \
+ $(INSTALL_DATA) $$f $(exampledir)/$$f; \
+ done
diff --git a/sys-apps/groff/groff-1.19.1-r2.ebuild b/sys-apps/groff/groff-1.19.1-r2.ebuild
index 2d90039c5835..19a45357a596 100644
--- a/sys-apps/groff/groff-1.19.1-r2.ebuild
+++ b/sys-apps/groff/groff-1.19.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.12 2005/03/14 23:45:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.13 2005/04/27 03:47:17 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -43,6 +43,7 @@ src_unpack() {
# Fix make dependencies so we can build in parallel
epatch ${FILESDIR}/${P}-parallel-make.patch
+
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then
sed -i \