summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-11-07 06:10:09 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-11-07 06:10:09 +0000
commit0a239aaf49b52504becdd4a192584a1104354e61 (patch)
tree4cba9f097ad94259ac5009f386c0c6ee20768a01 /sys-apps/groff
parentbump to 2.6.31-zen7 (diff)
downloadgentoo-2-0a239aaf49b52504becdd4a192584a1104354e61.tar.gz
gentoo-2-0a239aaf49b52504becdd4a192584a1104354e61.tar.bz2
gentoo-2-0a239aaf49b52504becdd4a192584a1104354e61.zip
Fixed japanese patch, bug #290103.
(Portage version: 2.1.7.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog8
-rw-r--r--sys-apps/groff/groff-1.20.1-r2.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index d6cdc677901c..26647379947a 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/groff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.102 2009/08/16 04:38:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.103 2009/11/07 06:10:09 matsuu Exp $
+
+*groff-1.20.1-r2 (07 Nov 2009)
+
+ 05 Nov 2009; MATSUU Takuto <matsuu@gentoo.org> +groff-1.20.1-r2.ebuild:
+ Fixed japanese patch, bug #290103. The patch was submitted by Naohiro
+ Aota.
16 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
groff-1.20.1-r1.ebuild:
diff --git a/sys-apps/groff/groff-1.20.1-r2.ebuild b/sys-apps/groff/groff-1.20.1-r2.ebuild
new file mode 100644
index 000000000000..7634def9f006
--- /dev/null
+++ b/sys-apps/groff/groff-1.20.1-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.20.1-r2.ebuild,v 1.1 2009/11/07 06:10:09 matsuu Exp $
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+SRC_URI="mirror://gnu/groff/${P}.tar.gz
+ linguas_ja? ( mirror://gentoo/${PF}-japanese.patch.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="examples X linguas_ja"
+
+DEPEND=">=sys-apps/texinfo-4.7-r1
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXaw
+ x11-libs/libSM
+ x11-libs/libICE
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+
+ # put the docs in the Gentoo-specific spot
+ sed -i \
+ -e '/^docdir=/s/=.*/=@docdir@/' \
+ Makefile.in \
+ || die "sed failed"
+
+ # Make sure we can cross-compile this puppy
+ if tc-is-cross-compiler ; then
+ sed -i \
+ -e '/^GROFFBIN=/s:=.*:=/usr/bin/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=/usr/bin/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
+ -e '/^GROFF_BIN_DIR=/s:=.*:=:' \
+ contrib/*/Makefile.sub \
+ doc/Makefile.in \
+ doc/Makefile.sub || die "cross-compile sed failed"
+ fi
+
+ cat <<-EOF >> tmac/mdoc.local
+ .ds volume-operating-system Gentoo
+ .ds operating-system Gentoo/${KERNEL}
+ .ds default-operating-system Gentoo/${KERNEL}
+ EOF
+
+ if use linguas_ja ; then
+ epatch "${WORKDIR}"/${PF}-japanese.patch #255292
+ eautoconf
+ eautoheader
+ fi
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+# tc-export CC CXX
+ econf \
+ --with-appresdir=/usr/share/X11/app-defaults \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with X x) \
+ $(use linguas_ja && echo --enable-japanese)
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # The following links are required for man #123674
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+
+ dodoc BUG-REPORT ChangeLog MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+
+ if ! use examples ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/examples
+ fi
+}