summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-02-27 20:34:19 +0000
committerAron Griffis <agriffis@gentoo.org>2003-02-27 20:34:19 +0000
commite51a7b50371d8b8b17806387a41843f2de910708 (patch)
treef6dfd86ffb98820744ae282a793d7939380aef2e /sys-apps/grep
parentStable on x86 (diff)
downloadgentoo-2-e51a7b50371d8b8b17806387a41843f2de910708.tar.gz
gentoo-2-e51a7b50371d8b8b17806387a41843f2de910708.tar.bz2
gentoo-2-e51a7b50371d8b8b17806387a41843f2de910708.zip
fix bug #16495
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog8
-rw-r--r--sys-apps/grep/files/digest-grep-2.5.1-r11
-rw-r--r--sys-apps/grep/grep-2.5.1-r1.ebuild40
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 3473e34bd381..00c40cfbcc3f 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/grep
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.11 2003/02/27 12:55:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.12 2003/02/27 20:34:19 agriffis Exp $
+
+*grep-2.5.1-r1 (27 Feb 2003)
+
+ 27 Feb 2003; Aron Griffis <agriffis@gentoo.org> grep-2.5.1-r1.ebuild:
+ Close bug #16495 by installing in /bin instead of /usr/bin. I introduced
+ this error in the 2.5.1 ebuild. Thanks to Tristan Henderson who noticed it.
*grep-2.5.1 (27 Feb 2003)
diff --git a/sys-apps/grep/files/digest-grep-2.5.1-r1 b/sys-apps/grep/files/digest-grep-2.5.1-r1
new file mode 100644
index 000000000000..76fdde6d78ce
--- /dev/null
+++ b/sys-apps/grep/files/digest-grep-2.5.1-r1
@@ -0,0 +1 @@
+MD5 85df024edc9f9689035f6b3de28c7731 grep-2.5.1.tar.gz 68309
diff --git a/sys-apps/grep/grep-2.5.1-r1.ebuild b/sys-apps/grep/grep-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..bbbd744a291d
--- /dev/null
+++ b/sys-apps/grep/grep-2.5.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r1.ebuild,v 1.1 2003/02/27 20:34:19 agriffis Exp $
+
+IUSE="nls build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU regular expression matcher"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/${PN}/${P}.tar.gz
+ ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/grep/grep.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf --bindir=/bin \
+ --disable-perl-regexp \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall bindir=${D}/bin || die "einstall failed"
+
+ if use build; then
+ rm -rf ${D}/usr/share
+ else
+ dodoc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
+ fi
+}
+