summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-04-25 02:14:43 +0000
committerJason Wever <weeve@gentoo.org>2003-04-25 02:14:43 +0000
commit8cb1d5e0784899f6595acd0ca4b28d004ec35f27 (patch)
tree1b1479b0c8373aeaa422af02b6933128b1b625ae /sys-apps/grep
parentBump (diff)
downloadgentoo-2-8cb1d5e0784899f6595acd0ca4b28d004ec35f27.tar.gz
gentoo-2-8cb1d5e0784899f6595acd0ca4b28d004ec35f27.tar.bz2
gentoo-2-8cb1d5e0784899f6595acd0ca4b28d004ec35f27.zip
Added patch for sparc32 to fix bug #17568
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog7
-rw-r--r--sys-apps/grep/files/gentoo-sparc32-dfa.patch11
-rw-r--r--sys-apps/grep/grep-2.5-r1.ebuild14
-rw-r--r--sys-apps/grep/grep-2.5.1-r1.ebuild12
-rw-r--r--sys-apps/grep/grep-2.5.1.ebuild12
5 files changed, 52 insertions, 4 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 00c40cfbcc3f..ca5becf807ef 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-apps/grep
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.12 2003/02/27 20:34:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.13 2003/04/25 02:14:42 weeve Exp $
*grep-2.5.1-r1 (27 Feb 2003)
@@ -10,6 +10,11 @@
*grep-2.5.1 (27 Feb 2003)
+ 24 Apr 2003; Jason Wever <weeve@gentoo.org> grep-2.5-r1.ebuild,
+ grep-2.5.1-r1.ebuild, grep-2.5.1.ebuild:
+ Added a patch for sparc32 to fix bug #17568. Thanks to Peter Gnodde
+ <peter@gnodde.org> for reporting the problem and solution.
+
27 Feb 2003; Aron Griffis <agriffis@gentoo.org> grep-2.5.1.ebuild:
Update to 2.5.1, thanks to Michael Sterrett for the heads-up
diff --git a/sys-apps/grep/files/gentoo-sparc32-dfa.patch b/sys-apps/grep/files/gentoo-sparc32-dfa.patch
new file mode 100644
index 000000000000..20295fc43fdd
--- /dev/null
+++ b/sys-apps/grep/files/gentoo-sparc32-dfa.patch
@@ -0,0 +1,11 @@
+*** src/dfa.h Fri Apr 25 01:36:02 2003
+--- src/dfa.h.mod Fri Apr 25 01:36:56 2003
+***************
+*** 428,432 ****
+--- 428,433 ----
+
+ /* dfaerror() is called by the regexp routines whenever an error occurs. It
+ takes a single argument, a NUL-terminated string describing the error.
+ The user must supply a dfaerror. */
+ extern void dfaerror PARAMS ((const char *));
++
diff --git a/sys-apps/grep/grep-2.5-r1.ebuild b/sys-apps/grep/grep-2.5-r1.ebuild
index 84e4d837400a..0d8e9d125ac3 100644
--- a/sys-apps/grep/grep-2.5-r1.ebuild
+++ b/sys-apps/grep/grep-2.5-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5-r1.ebuild,v 1.16 2003/02/21 02:34:19 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5-r1.ebuild,v 1.17 2003/04/25 02:14:43 weeve Exp $
+
+inherit eutils
IUSE="nls build"
@@ -17,6 +19,16 @@ LICENSE="GPL-2"
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ echo ${PROFILE_ARCH}
+ if [ "${ARCH}" = "sparc" -a "${PROFILE_ARCH}" = "sparc" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/gentoo-sparc32-dfa.patch || die
+ fi
+}
+
src_compile() {
local myconf=""
use nls || myconf="--disable-nls"
diff --git a/sys-apps/grep/grep-2.5.1-r1.ebuild b/sys-apps/grep/grep-2.5.1-r1.ebuild
index bbbd744a291d..96f6c41c3d09 100644
--- a/sys-apps/grep/grep-2.5.1-r1.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r1.ebuild,v 1.1 2003/02/27 20:34:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r1.ebuild,v 1.2 2003/04/25 02:14:43 weeve Exp $
IUSE="nls build"
@@ -17,6 +17,16 @@ LICENSE="GPL-2"
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ echo ${PROFILE_ARCH}
+ if [ "${ARCH}" = "sparc" -a "${PROFILE_ARCH}" = "sparc" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/gentoo-sparc32-dfa.patch || die
+ fi
+}
+
src_compile() {
local myconf=""
use nls || myconf="--disable-nls"
diff --git a/sys-apps/grep/grep-2.5.1.ebuild b/sys-apps/grep/grep-2.5.1.ebuild
index 15dc6cc913a1..acba77ba6e7b 100644
--- a/sys-apps/grep/grep-2.5.1.ebuild
+++ b/sys-apps/grep/grep-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1.ebuild,v 1.1 2003/02/27 12:55:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1.ebuild,v 1.2 2003/04/25 02:14:43 weeve Exp $
IUSE="nls build"
@@ -17,6 +17,16 @@ LICENSE="GPL-2"
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ echo ${PROFILE_ARCH}
+ if [ "${ARCH}" = "sparc" -a "${PROFILE_ARCH}" = "sparc" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/gentoo-sparc32-dfa.patch || die
+ fi
+}
+
src_compile() {
local myconf=""
use nls || myconf="--disable-nls"