summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-15 07:09:54 +0000
committerNed Ludd <solar@gentoo.org>2004-06-15 07:09:54 +0000
commit6d402876a4cf8d2870689730b6272e946d88ac06 (patch)
treef94870c334be14eed8d4a7cc1ad4b2b98a9a89f7 /sys-apps/grep
parentrun gnuconfig_update when using uclibc (Manifest recommit) (diff)
downloadgentoo-2-6d402876a4cf8d2870689730b6272e946d88ac06.tar.gz
gentoo-2-6d402876a4cf8d2870689730b6272e946d88ac06.tar.bz2
gentoo-2-6d402876a4cf8d2870689730b6272e946d88ac06.zip
added uclibc support
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog6
-rw-r--r--sys-apps/grep/files/grep-2.5.1-restrict_arr.patch12
-rw-r--r--sys-apps/grep/grep-2.5.1-r1.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index 70edf9060796..d3f812b4ab62 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/grep
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.27 2004/06/12 05:36:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.28 2004/06/15 07:06:41 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> grep-2.5.1-r1.ebuild,
+ files/grep-2.5.1-restrict_arr.patch:
+ added uclibc support
*grep-2.5.1-r4 (11 Jun 2004)
diff --git a/sys-apps/grep/files/grep-2.5.1-restrict_arr.patch b/sys-apps/grep/files/grep-2.5.1-restrict_arr.patch
new file mode 100644
index 000000000000..aa71bbcb9db0
--- /dev/null
+++ b/sys-apps/grep/files/grep-2.5.1-restrict_arr.patch
@@ -0,0 +1,12 @@
+--- lib/posix/regex.h.mps 2004-06-09 22:00:00.000000000 +0200
++++ lib/posix/regex.h 2004-06-09 22:00:40.000000000 +0200
+@@ -533,7 +533,9 @@ extern int re_exec _RE_ARGS ((const char
+ /* For now unconditionally define __restrict_arr to expand to nothing.
+ Ideally we would have a test for the compiler which allows defining
+ it to restrict. */
++#ifndef __restrict_arr
+ #define __restrict_arr
++#endif
+
+ /* POSIX compatibility. */
+ extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
diff --git a/sys-apps/grep/grep-2.5.1-r1.ebuild b/sys-apps/grep/grep-2.5.1-r1.ebuild
index f24955509de9..553b663561d4 100644
--- a/sys-apps/grep/grep-2.5.1-r1.ebuild
+++ b/sys-apps/grep/grep-2.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r1.ebuild,v 1.21 2004/04/29 01:09:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r1.ebuild,v 1.22 2004/06/15 07:06:41 solar Exp $
inherit gnuconfig flag-o-matic eutils
@@ -13,7 +13,7 @@ SRC_URI="http://ftp.club.cc.cmu.edu/pub/gnu/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="nls build"
+IUSE="nls build uclibc"
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
@@ -25,6 +25,7 @@ src_unpack() {
if [ "${ARCH}" = "sparc" -a "${PROFILE_ARCH}" = "sparc" ] ; then
epatch ${FILESDIR}/gentoo-sparc32-dfa.patch
fi
+ use uclibc && epatch ${FILESDIR}/grep-2.5.1-restrict_arr.patch
}
src_compile() {
@@ -33,6 +34,7 @@ src_compile() {
local myconf=""
use nls || myconf="--disable-nls"
+ use uclibc && myconf="${myconf} --without-included-regex"
use static && append-flags -static && append-ldflags -static
econf \