summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/gluelog
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/gluelog')
-rw-r--r--sys-apps/gluelog/gluelog-1.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/gluelog/gluelog-1.0-r2.ebuild b/sys-apps/gluelog/gluelog-1.0-r2.ebuild
new file mode 100644
index 000000000000..44e29dc3cc58
--- /dev/null
+++ b/sys-apps/gluelog/gluelog-1.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gluelog/gluelog-1.0-r2.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Pipe and socket fittings for the system and kernel logs"
+SRC_URI=""
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ mkdir ${S}
+
+ cd ${FILESDIR}
+ try gcc ${CFLAGS} gluelog.c -o ${S}/gluelog
+ try gcc ${CFLAGS} glueklog.c -o ${S}/glueklog
+}
+
+src_install() {
+
+ dodir /usr/sbin
+ dosbin ${S}/gluelog ${S}/glueklog
+ exeopts -m0750 -g wheel
+ dodir /var/log
+ local x
+ for x in syslog klog
+ do
+ exeinto /var/lib/supervise/services/${x}
+ newexe ${FILESDIR}/${x}-run run
+ install -d -m0750 -o daemon -g wheel ${D}/var/log/${x}.d
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/svc-${x}
+ done
+
+ dodoc ${FILESDIR}/README
+
+}
+