summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-01 06:26:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-01 06:26:58 +0000
commit2137c1d463cf931cf3524a7e94eb8552187a853e (patch)
tree07652fb7cb5f926c1fd695c92daef1f86b67f44a /sys-apps/gawk
parentremove trailing / so cp doesnt get angry #104305 by Chris Fairles (diff)
downloadgentoo-2-2137c1d463cf931cf3524a7e94eb8552187a853e.tar.gz
gentoo-2-2137c1d463cf931cf3524a7e94eb8552187a853e.tar.bz2
gentoo-2-2137c1d463cf931cf3524a7e94eb8552187a853e.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog8
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.52
-rw-r--r--sys-apps/gawk/files/gawk-3.1.5-core.patch31
-rw-r--r--sys-apps/gawk/gawk-3.1.5.ebuild113
4 files changed, 153 insertions, 1 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 8f9cdcddc2a5..d008f05905c9 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.55 2005/05/30 02:36:42 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.56 2005/09/01 06:26:58 vapier Exp $
+
+*gawk-3.1.5 (01 Sep 2005)
+
+ 01 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gawk-3.1.5-core.patch, +gawk-3.1.5.ebuild:
+ Version bump.
29 May 2005; <solar@gentoo.org> gawk-3.1.3-r2.ebuild:
echangelog - update package to use libc expanded variable elibc_uclibc vs
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.5 b/sys-apps/gawk/files/digest-gawk-3.1.5
new file mode 100644
index 000000000000..5a1ad05d144f
--- /dev/null
+++ b/sys-apps/gawk/files/digest-gawk-3.1.5
@@ -0,0 +1,2 @@
+MD5 4760325489479cac17fe0114b8f62f30 gawk-3.1.5.tar.gz 2310919
+MD5 828fbed5314eab4dd0f75ce32dc28bda patch_3.1.4__xml_20040920 79433
diff --git a/sys-apps/gawk/files/gawk-3.1.5-core.patch b/sys-apps/gawk/files/gawk-3.1.5-core.patch
new file mode 100644
index 000000000000..5dc134c78f22
--- /dev/null
+++ b/sys-apps/gawk/files/gawk-3.1.5-core.patch
@@ -0,0 +1,31 @@
+fix an ugly core on a simple script
+
+http://lists.gnu.org/archive/html/bug-gnu-utils/2005-08/msg00040.html
+http://lists.gnu.org/archive/html/bug-gnu-utils/2005-08/msg00047.html
+
+--- io.c
++++ io.c
+@@ -2480,9 +2480,12 @@
+ {
+ struct stat sbuf;
+ struct open_hook *oh;
++ int iop_malloced = FALSE;
+
+- if (iop == NULL)
++ if (iop == NULL) {
+ emalloc(iop, IOBUF *, sizeof(IOBUF), "iop_alloc");
++ iop_malloced = TRUE;
++ }
+ memset(iop, '\0', sizeof(IOBUF));
+ iop->flag = 0;
+ iop->fd = fd;
+@@ -2495,7 +2498,8 @@
+ }
+
+ if (iop->fd == INVALID_HANDLE) {
+- free(iop);
++ if (iop_malloced)
++ free(iop);
+ return NULL;
+ }
+ if (isatty(iop->fd))
diff --git a/sys-apps/gawk/gawk-3.1.5.ebuild b/sys-apps/gawk/gawk-3.1.5.ebuild
new file mode 100644
index 000000000000..ee93033cbd5e
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.1.5.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.5.ebuild,v 1.1 2005/09/01 06:26:58 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
+IUSE="nls build"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+SFFS=${WORKDIR}/filefuncs
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ # Copy filefuncs module's source over ...
+ cp -pPR "${FILESDIR}"/filefuncs "${SFFS}" || die "cp failed"
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-core.patch
+ epatch "${FILESDIR}"/${PN}-3.1.3-getpgrp_void.patch #fedora
+ # support for dec compiler.
+ [[ $(tc-getCC) == "ccc" ]] && epatch "${FILESDIR}"/${PN}-3.1.2-dec-alpha-compiler.diff
+}
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ --enable-switch \
+ || die
+ emake || die "emake failed"
+
+ cd "${SFFS}"
+ emake AWKINCDIR="${S}" CC=$(tc-getCC) || die "filefuncs emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ if ! use userland_Darwin ; then
+ cd "${SFFS}"
+ make \
+ DESTDIR="${D}" \
+ AWKINCDIR="${S}" \
+ LIBDIR="$(get_libdir)" \
+ install \
+ || die "filefuncs install failed"
+ fi
+
+ dodir /usr/bin
+ # In some rare cases, (p)gawk gets installed as (p)gawk- and not
+ # (p)gawk-${PV} ... Also make sure that /bin/(p)gawk is a symlink
+ # to /bin/(p)gawk-${PV}.
+ local binpath x
+ for x in gawk pgawk igawk ; do
+ [[ ${x} == "gawk" ]] \
+ && binpath="/bin" \
+ || binpath="/usr/bin"
+
+ if [[ -f ${D}/bin/${x} && ! -f ${D}/bin/${x}-${PV} ]] ; then
+ mv -f "${D}"/bin/${x} "${D}"/${binpath}/${x}-${PV}
+ elif [[ -f ${D}/bin/${x}- && ! -f ${D}/bin/${x}-${PV} ]] ; then
+ mv -f "${D}"/bin/${x}- "${D}"/${binpath}/${x}-${PV}
+ elif [[ ${binpath} == "/usr/bin" && -f ${D}/bin/${x}-${PV} ]] ; then
+ mv -f "${D}"/bin/${x}-${PV} "${D}"/${binpath}/${x}-${PV}
+ fi
+
+ rm -f "${D}"/bin/${x}
+ dosym ${x}-${PV} ${binpath}/${x}
+ [[ ${binpath} == "/usr/bin" ]] && dosym /usr/bin/${x}-${PV} /bin/${x}
+ done
+
+ rm -f "${D}"/bin/awk
+ dodir /usr/bin
+ # Compat symlinks
+ dosym /bin/gawk-${PV} /usr/bin/gawk
+ dosym gawk-${PV} /bin/awk
+ dosym /bin/gawk-${PV} /usr/bin/awk
+ [[ ${USERLAND} != "GNU" ]] && rm -f "${D}"/{,usr/}bin/awk{,-${PV}}
+
+ # Install headers
+ insinto /usr/include/awk
+ doins "${S}"/*.h || die "ins headers failed"
+ # We do not want 'acconfig.h' in there ...
+ rm -f "${D}"/usr/include/awk/acconfig.h
+
+ if ! use build ; then
+ cd "${S}"
+ rm -f "${D}"/usr/share/man/man1/pgawk.1
+ dosym gawk.1.gz /usr/share/man/man1/pgawk.1.gz
+ [[ ${USERLAND} == "GNU" ]] && dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README
+ docinto README_d
+ dodoc README_d/*
+ docinto awklib
+ dodoc awklib/ChangeLog
+ docinto pc
+ dodoc pc/ChangeLog
+ docinto posix
+ dodoc posix/ChangeLog
+ else
+ rm -r "${D}"/usr/share
+ fi
+}