summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-03 20:31:42 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-03 20:31:42 +0000
commit197168cdb346388f6705136f7a2324c51de9134d (patch)
tree38f8711553273eabe90661680ac189d22f619338 /sys-apps/gawk
parentStable on ppc64 (diff)
downloadgentoo-2-197168cdb346388f6705136f7a2324c51de9134d.tar.gz
gentoo-2-197168cdb346388f6705136f7a2324c51de9134d.tar.bz2
gentoo-2-197168cdb346388f6705136f7a2324c51de9134d.zip
Fix by Kito for building with gcc4 #104740 and move a bunch of ugly filefunc details out of the ebuild and into the filefunc Makefile.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog7
-rw-r--r--sys-apps/gawk/files/filefuncs/Makefile23
-rw-r--r--sys-apps/gawk/files/gawk-3.1.5-gcc4.patch23
-rw-r--r--sys-apps/gawk/gawk-3.1.5.ebuild16
4 files changed, 56 insertions, 13 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index fd693a0a93ac..dfb42162191a 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.60 2005/09/02 19:31:55 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.61 2005/09/03 20:31:42 vapier Exp $
+
+ 03 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gawk-3.1.5-gcc4.patch, files/filefuncs/Makefile, gawk-3.1.5.ebuild:
+ Fix by Kito for building with gcc4 #104740 and move a bunch of ugly filefunc
+ details out of the ebuild and into the filefunc Makefile.
02 Sep 2005; Michael Hanselmann <hansmi@gentoo.org> gawk-3.1.4-r4.ebuild:
Stable on ppc.
diff --git a/sys-apps/gawk/files/filefuncs/Makefile b/sys-apps/gawk/files/filefuncs/Makefile
index c3d99de9328e..bd2cfca7ee94 100644
--- a/sys-apps/gawk/files/filefuncs/Makefile
+++ b/sys-apps/gawk/files/filefuncs/Makefile
@@ -1,7 +1,7 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.6 2005/05/14 17:56:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.7 2005/09/03 20:31:42 vapier Exp $
CC ?= gcc
LD = $(CC)
@@ -17,6 +17,21 @@ TARGET_LIB = $(TARGET).so.$(MAJORVER).$(MINORVER)
LIBDIR = lib
+# Gentoo specific cruft, you like it dont ya idiot
+ifdef D
+DESTDIR = $(D)
+endif
+ifdef S
+AWKINCDIR = $(S)
+endif
+
+DOIT = yes
+ifeq ($(USERLAND),Darwin)
+DOIT = no
+endif
+
+ifeq ($(DOIT),yes)
+
all: $(TARGET_LIB)
$(TARGET).o: $(TARGET).c
@@ -34,3 +49,9 @@ install: $(TARGET_LIB)
clean:
rm -f $(TARGET)
rm -f *.o *~ core
+
+else
+
+all install clean:
+
+endif
diff --git a/sys-apps/gawk/files/gawk-3.1.5-gcc4.patch b/sys-apps/gawk/files/gawk-3.1.5-gcc4.patch
new file mode 100644
index 000000000000..3ebadcbe6684
--- /dev/null
+++ b/sys-apps/gawk/files/gawk-3.1.5-gcc4.patch
@@ -0,0 +1,23 @@
+Sat Sep 3 16:03:25 EDT 2005 Kito Danya Dietrich <kito@gentoo.org>
+
+ * hard-locale.h (hard_locale): Declare xmalloc in global scope rather than
+ function scope which gcc-4.x rejects.
+
+--- gawk-3.1.5/hard-locale.h
++++ gawk-3.1.5/hard-locale.h
+@@ -21,6 +21,7 @@
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
+
++static ptr_t xmalloc PARAMS ((size_t n));
+
+ /* Return nonzero if the current CATEGORY locale is hard, i.e. if you
+ can't get away with assuming traditional C or POSIX behavior. */
+@@ -40,7 +41,6 @@
+ if (strcmp (p, "C") == 0 || strcmp (p, "POSIX") == 0)
+ hard = 0;
+ # else
+- static ptr_t xmalloc PARAMS ((size_t n));
+
+ char *locale = xmalloc (strlen (p) + 1);
+ strcpy (locale, p);
diff --git a/sys-apps/gawk/gawk-3.1.5.ebuild b/sys-apps/gawk/gawk-3.1.5.ebuild
index fda7e6d69bb1..19af88072839 100644
--- a/sys-apps/gawk/gawk-3.1.5.ebuild
+++ b/sys-apps/gawk/gawk-3.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.5.ebuild,v 1.3 2005/09/02 05:11:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.5.ebuild,v 1.4 2005/09/03 20:31:42 vapier Exp $
inherit eutils toolchain-funcs
@@ -27,6 +27,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-core.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
epatch "${FILESDIR}"/${PN}-3.1.3-getpgrp_void.patch #fedora
# support for dec compiler.
[[ $(tc-getCC) == "ccc" ]] && epatch "${FILESDIR}"/${PN}-3.1.2-dec-alpha-compiler.diff
@@ -41,20 +42,13 @@ src_compile() {
emake || die "emake failed"
cd "${SFFS}"
- emake AWKINCDIR="${S}" CC=$(tc-getCC) || die "filefuncs emake failed"
+ emake CC=$(tc-getCC) || die "filefuncs emake failed"
}
src_install() {
make install DESTDIR="${D}" || die "install failed"
- if ! use userland_Darwin ; then
- cd "${SFFS}"
- make \
- DESTDIR="${D}" \
- AWKINCDIR="${S}" \
- LIBDIR="$(get_libdir)" \
- install \
- || die "filefuncs install failed"
- fi
+ cd "${SFFS}"
+ make LIBDIR="$(get_libdir)" install || die "filefuncs install failed"
dodir /usr/bin
# In some rare cases, (p)gawk gets installed as (p)gawk- and not