summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-14 07:29:54 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-14 07:29:54 +0000
commite94c06300bfe5c527f7fc483dcf675d20e059f83 (patch)
tree252fa0b849917a839ef25446094818c4c20cddb3 /sys-apps/findutils
parentVersion bump by Vladimir #280434. (diff)
downloadgentoo-2-e94c06300bfe5c527f7fc483dcf675d20e059f83.tar.gz
gentoo-2-e94c06300bfe5c527f7fc483dcf675d20e059f83.tar.bz2
gentoo-2-e94c06300bfe5c527f7fc483dcf675d20e059f83.zip
Version bump #279673 by Lars Wendler.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/findutils-4.5.5.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index f6ceb8699349..ca1d6ebb350c 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.179 2009/03/15 21:05:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.180 2009/08/14 07:29:54 vapier Exp $
+
+*findutils-4.5.5 (14 Aug 2009)
+
+ 14 Aug 2009; Mike Frysinger <vapier@gentoo.org> +findutils-4.5.5.ebuild:
+ Version bump #279673 by Lars Wendler.
*findutils-4.5.4 (15 Mar 2009)
diff --git a/sys-apps/findutils/findutils-4.5.5.ebuild b/sys-apps/findutils/findutils-4.5.5.ebuild
new file mode 100644
index 000000000000..aa894130024d
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.5.ebuild,v 1.1 2009/08/14 07:29:54 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SELINUX_PATCH="findutils-4.5.4-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+# mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}