summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 14:41:16 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 14:41:16 +0000
commit451ff9161ae58d7d0f1eb4351999c19b04228b99 (patch)
tree9fffef93fde0bf15989ca770099827cee37280b1 /sys-apps/findutils
parentAdded USE dependent nls compilation (diff)
downloadgentoo-2-451ff9161ae58d7d0f1eb4351999c19b04228b99.tar.gz
gentoo-2-451ff9161ae58d7d0f1eb4351999c19b04228b99.tar.bz2
gentoo-2-451ff9161ae58d7d0f1eb4351999c19b04228b99.zip
Added USE dependent nls compilation
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog8
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.1.7-r11
-rw-r--r--sys-apps/findutils/findutils-4.1.7-r1.ebuild51
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 0f8341888b2e..e4e963834eaf 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/findutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.1 2002/02/01 21:53:37 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.2 2002/03/12 14:41:16 seemant Exp $
+
+*findutils-4.1.7-r1 (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
+
+ Added USE dependent nls compilation
*findutils-4.1.7 (1 Feb 2002)
diff --git a/sys-apps/findutils/files/digest-findutils-4.1.7-r1 b/sys-apps/findutils/files/digest-findutils-4.1.7-r1
new file mode 100644
index 000000000000..71e0d8a53382
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.1.7-r1
@@ -0,0 +1 @@
+MD5 582d9b35006065f81f71d681c165fa1e findutils-4.1.7.tar.gz 634058
diff --git a/sys-apps/findutils/findutils-4.1.7-r1.ebuild b/sys-apps/findutils/findutils-4.1.7-r1.ebuild
new file mode 100644
index 000000000000..0eef231bc9ca
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.1.7-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.7-r1.ebuild,v 1.1 2002/03/12 14:41:16 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU utilities to find files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --localstatedir=/var/spool/locate \
+ ${myconf} || die
+
+ emake libexecdir=/usr/lib/find || die
+}
+
+src_install() {
+ #do not change 'localstatedir=/var/spool/locate' to
+ #'localstatedir=${D}/var/spool/locate', as it will then be hardcoded
+ #into locate and updatedb
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=/var/spool/locate \
+ libexecdir=${D}/usr/lib/find \
+ install || die
+
+ dosed "s:TMPDIR=/usr/tmp:TMPDIR=/tmp:" usr/bin/updatedb
+ rm -rf ${D}/usr/var
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING NEWS README TODO ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+ dodir /var/spool/locate
+ touch ${D}/var/spool/locate/.keep
+}
+