summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-27 04:50:37 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-27 04:50:37 +0000
commitec6c2c752577053efd1555e15f3b30199ea38f4b (patch)
tree765cb53a3f5aa756583ecca43e9cec86721c027f /sys-apps/file
parentTweak patch so we use CFLAGS when linking. (diff)
downloadgentoo-2-ec6c2c752577053efd1555e15f3b30199ea38f4b.tar.gz
gentoo-2-ec6c2c752577053efd1555e15f3b30199ea38f4b.tar.bz2
gentoo-2-ec6c2c752577053efd1555e15f3b30199ea38f4b.zip
Version bump and update live ebuild. Move to EAPI 4 and convert to distutils-r1 (bug #460010, patch by mgorny).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog9
-rw-r--r--sys-apps/file/file-5.15.ebuild94
-rw-r--r--sys-apps/file/file-9999.ebuild31
3 files changed, 114 insertions, 20 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 5466d59421b3..07cfe6b46f7b 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.243 2013/09/05 09:51:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.244 2013/09/27 04:50:37 radhermit Exp $
+
+*file-5.15 (27 Sep 2013)
+
+ 27 Sep 2013; Tim Harder <radhermit@gentoo.org> +file-5.15.ebuild,
+ file-9999.ebuild:
+ Version bump and update live ebuild. Move to EAPI 4 and convert to
+ distutils-r1 (bug #460010, patch by mgorny).
05 Sep 2013; Mike Frysinger <vapier@gentoo.org> file-5.12-r1.ebuild:
Mark m68k stable #467188.
diff --git a/sys-apps/file/file-5.15.ebuild b/sys-apps/file/file-5.15.ebuild
new file mode 100644
index 000000000000..db24c09c7ceb
--- /dev/null
+++ b/sys-apps/file/file-5.15.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.15.ebuild,v 1.1 2013/09/27 04:50:37 radhermit Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+DISTUTILS_OPTIONAL=1
+
+inherit eutils distutils-r1 libtool toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/glensc/file.git"
+ inherit autotools git-r3
+else
+ SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="http://www.darwinsys.com/file/"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="python static-libs zlib"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+ elibtoolize
+
+ # don't let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+wd() { echo "${WORKDIR}"/build-${CHOST}; }
+
+do_configure() {
+ ECONF_SOURCE=${S}
+
+ mkdir "$(wd)"
+ pushd "$(wd)" >/dev/null
+
+ econf "$@"
+
+ popd >/dev/null
+}
+
+src_configure() {
+ # when cross-compiling, we need to build up our own file
+ # because people often don't keep matching host/target
+ # file versions #362941
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ tc-export_build_env BUILD_C{C,XX}
+ ac_cv_header_zlib_h=no \
+ ac_cv_lib_z_gzopen=no \
+ CHOST=${CBUILD} \
+ CFLAGS=${BUILD_CFLAGS} \
+ CXXFLAGS=${BUILD_CXXFLAGS} \
+ CPPFLAGS=${BUILD_CPPFLAGS} \
+ LDFLAGS="${BUILD_LDFLAGS} -static" \
+ CC=${BUILD_CC} \
+ CXX=${BUILD_CXX} \
+ do_configure --disable-shared
+ fi
+
+ export ac_cv_header_zlib_h=$(usex zlib) ac_cv_lib_z_gzopen=$(usex zlib)
+ do_configure $(use_enable static-libs static)
+}
+
+do_make() {
+ emake -C "$(wd)" "$@"
+}
+
+src_compile() {
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ CHOST=${CBUILD} do_make -C src file
+ PATH=$(CHOST=${CBUILD} wd)/src:${PATH}
+ fi
+ do_make
+
+ use python && cd python && distutils-r1_src_compile
+}
+
+src_install() {
+ do_make DESTDIR="${D}" install
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils-r1_src_install
+ prune_libtool_files
+}
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index a027051ca1b2..c636422d5666 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-9999.ebuild,v 1.2 2013/01/16 03:44:29 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-9999.ebuild,v 1.3 2013/09/27 04:50:37 radhermit Exp $
EAPI="4"
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+DISTUTILS_OPTIONAL=1
-inherit eutils distutils libtool toolchain-funcs
+inherit eutils distutils-r1 libtool toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/glensc/file.git"
- inherit autotools git-2
+ inherit autotools git-r3
else
SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
@@ -25,11 +24,10 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="python static-libs zlib"
-RDEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}"
-PYTHON_MODNAME="magic.py"
-
src_prepare() {
[[ ${PV} == "9999" ]] && eautoreconf
elibtoolize
@@ -39,6 +37,7 @@ src_prepare() {
}
wd() { echo "${WORKDIR}"/build-${CHOST}; }
+
do_configure() {
ECONF_SOURCE=${S}
@@ -49,6 +48,7 @@ do_configure() {
popd >/dev/null
}
+
src_configure() {
# when cross-compiling, we need to build up our own file
# because people often don't keep matching host/target
@@ -74,6 +74,7 @@ src_configure() {
do_make() {
emake -C "$(wd)" "$@"
}
+
src_compile() {
if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
CHOST=${CBUILD} do_make -C src file
@@ -81,21 +82,13 @@ src_compile() {
fi
do_make
- use python && cd python && distutils_src_compile
+ use python && cd python && distutils-r1_src_compile
}
src_install() {
do_make DESTDIR="${D}" install
dodoc ChangeLog MAINT README
- use python && cd python && distutils_src_install
+ use python && cd python && distutils-r1_src_install
prune_libtool_files
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}