summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-21 21:18:12 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-21 21:18:12 +0000
commitcb79d46de7f37c3ea7e6754bc88370f90443117b (patch)
tree9318d75ac8b91910b2e964fd4c1e6d48d924397a /sys-apps/file
parentRemove maintainer. Drop to maintainer-needed@gentoo.org (diff)
downloadgentoo-2-cb79d46de7f37c3ea7e6754bc88370f90443117b.tar.gz
gentoo-2-cb79d46de7f37c3ea7e6754bc88370f90443117b.tar.bz2
gentoo-2-cb79d46de7f37c3ea7e6754bc88370f90443117b.zip
Version bump.
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-5.14.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 3f97fd6a7ffa..ed182f7ae5ee 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.232 2013/02/09 06:52:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.233 2013/03/21 21:18:12 vapier Exp $
+
+*file-5.14 (21 Mar 2013)
+
+ 21 Mar 2013; Mike Frysinger <vapier@gentoo.org> +file-5.14.ebuild:
+ Version bump.
*file-5.12-r1 (09 Feb 2013)
diff --git a/sys-apps/file/file-5.14.ebuild b/sys-apps/file/file-5.14.ebuild
new file mode 100644
index 000000000000..63c8ada3f1fe
--- /dev/null
+++ b/sys-apps/file/file-5.14.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.14.ebuild,v 1.1 2013/03/21 21:18:12 vapier Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils distutils libtool toolchain-funcs
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="python static-libs zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="magic.py"
+
+src_prepare() {
+ elibtoolize
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+wd() { echo "${WORKDIR}"/build-${CHOST}; }
+do_configure() {
+ ECONF_SOURCE=${S}
+
+ mkdir "$(wd)"
+ pushd "$(wd)" >/dev/null
+
+ econf "$@"
+
+ popd >/dev/null
+}
+src_configure() {
+ # when cross-compiling, we need to build up our own file
+ # because people often don't keep matching host/target
+ # file versions #362941
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ tc-export_build_env BUILD_C{C,XX}
+ ac_cv_header_zlib_h=no \
+ ac_cv_lib_z_gzopen=no \
+ CHOST=${CBUILD} \
+ CFLAGS=${BUILD_CFLAGS} \
+ CXXFLAGS=${BUILD_CXXFLAGS} \
+ CPPFLAGS=${BUILD_CPPFLAGS} \
+ LDFLAGS="${BUILD_LDFLAGS} -static" \
+ CC=${BUILD_CC} \
+ CXX=${BUILD_CXX} \
+ do_configure --disable-shared
+ fi
+
+ export ac_cv_header_zlib_h=$(usex zlib) ac_cv_lib_z_gzopen=$(usex zlib)
+ do_configure $(use_enable static-libs static)
+}
+
+do_make() {
+ emake -C "$(wd)" "$@" || die
+}
+src_compile() {
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ CHOST=${CBUILD} do_make -C src file
+ PATH=$(CHOST=${CBUILD} wd)/src:${PATH}
+ fi
+ do_make
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ do_make DESTDIR="${D}" install || die
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+ use static-libs || rm -f "${D}"/usr/lib*/libmagic.la
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}