summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-17 22:56:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-17 22:56:08 +0000
commit9b01463eb98f0c6af88db2fb96ae29f9aa9b9f86 (patch)
treef59b5bb209e4ced0b720354bdff1f859d91be88a /sys-apps/file
parentold (diff)
downloadgentoo-2-9b01463eb98f0c6af88db2fb96ae29f9aa9b9f86.tar.gz
gentoo-2-9b01463eb98f0c6af88db2fb96ae29f9aa9b9f86.tar.bz2
gentoo-2-9b01463eb98f0c6af88db2fb96ae29f9aa9b9f86.zip
Versin bump.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-4.16.ebuild57
-rw-r--r--sys-apps/file/files/digest-file-4.161
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 582cfd4b5ade..7e46a9939342 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.91 2005/10/08 16:16:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.92 2005/10/17 22:56:07 vapier Exp $
+
+*file-4.16 (17 Oct 2005)
+
+ 17 Oct 2005; Mike Frysinger <vapier@gentoo.org> +file-4.16.ebuild:
+ Versin bump.
*file-4.15-r1 (08 Oct 2005)
diff --git a/sys-apps/file/file-4.16.ebuild b/sys-apps/file/file-4.16.ebuild
new file mode 100644
index 000000000000..0514c66a0b86
--- /dev/null
+++ b/sys-apps/file/file-4.16.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.16.ebuild,v 1.1 2005/10/17 22:56:07 vapier Exp $
+
+inherit distutils libtool
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python build"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-empty-mime-buffer.patch #106152
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+ elibtoolize
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use build && return 0
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if ! use build ; then
+ dodoc ChangeLog MAINT README
+ use python && cd python && distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.16 b/sys-apps/file/files/digest-file-4.16
new file mode 100644
index 000000000000..3d24ff8345e6
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.16
@@ -0,0 +1 @@
+MD5 9bc5a7017ab7bd544f288fd931ec741a file-4.16.tar.gz 548877