summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-21 05:48:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-21 05:48:04 +0000
commit3a35cdac594d266bdf3b93e99415b9827b6383a4 (patch)
tree6de39e01f4dda08e763df9bbc32325915f2ca76e /sys-apps/file
parentget rid of duped cross compile patch (diff)
downloadgentoo-2-3a35cdac594d266bdf3b93e99415b9827b6383a4.tar.gz
gentoo-2-3a35cdac594d266bdf3b93e99415b9827b6383a4.tar.bz2
gentoo-2-3a35cdac594d266bdf3b93e99415b9827b6383a4.zip
grab a simple ia64 patch from redhat
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-4.13.ebuild5
-rw-r--r--sys-apps/file/files/file-4.12-cross-compile.patch30
-rw-r--r--sys-apps/file/files/file-4.13-ia64.patch16
3 files changed, 20 insertions, 31 deletions
diff --git a/sys-apps/file/file-4.13.ebuild b/sys-apps/file/file-4.13.ebuild
index 4ae711e0c8db..2328f7cb1caf 100644
--- a/sys-apps/file/file-4.13.ebuild
+++ b/sys-apps/file/file-4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.3 2005/05/21 04:48:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.4 2005/05/21 05:48:04 vapier Exp $
inherit flag-o-matic eutils distutils libtool toolchain-funcs
@@ -23,6 +23,9 @@ src_unpack() {
# the magic and src subdir sometimes don't get along #81974
sed -i -e '/^SUBDIRS/s:magic::' Makefile.in
+ # Rename ia64 labels (from Fedora)
+ epatch "${FILESDIR}"/${P}-ia64.patch
+
# This tweaks the output format for mips binaries so things like
# libtool don't barf all over the place when trying to parse it.
epatch "${FILESDIR}"/${PN}-4.xx-mips-gentoo.patch
diff --git a/sys-apps/file/files/file-4.12-cross-compile.patch b/sys-apps/file/files/file-4.12-cross-compile.patch
deleted file mode 100644
index b2b7d3c80707..000000000000
--- a/sys-apps/file/files/file-4.12-cross-compile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- file-4.10/magic/Makefile.in.orig 2004-07-24 14:38:55.000000000 -0600
-+++ file-4.10/magic/Makefile.in 2004-07-28 12:16:23.000000000 -0600
-@@ -490,10 +490,10 @@
- done >> $@
-
- magic.mgc: magic
-- $(top_builddir)/src/file -C -m magic
-+ /usr/bin/file -C -m magic
-
- magic.mime.mgc: magic.mime
-- $(top_builddir)/src/file -C -m $(srcdir)/magic.mime
-+ /usr/bin/file -C -m $(srcdir)/magic.mime
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
---- file-4.10/magic/Makefile.am.orig 2004-07-24 14:38:55.000000000 -0600
-+++ file-4.10/magic/Makefile.am 2004-07-28 12:18:15.000000000 -0600
-@@ -16,10 +16,10 @@
- done >> $@
-
- magic.mgc: magic
-- $(top_builddir)/src/file -C -m magic
-+ /usr/bin/file -C -m magic
-
- magic.mime.mgc: magic.mime
-- $(top_builddir)/src/file -C -m $(srcdir)/magic.mime
-+ /usr/bin/file -C -m $(srcdir)/magic.mime
-
- magic_FRAGMENTS = \
- Magdir/acorn \
diff --git a/sys-apps/file/files/file-4.13-ia64.patch b/sys-apps/file/files/file-4.13-ia64.patch
new file mode 100644
index 000000000000..afe6abaf7e86
--- /dev/null
+++ b/sys-apps/file/files/file-4.13-ia64.patch
@@ -0,0 +1,16 @@
+--- file-4.02/magic/Magdir/elf
++++ file-4.02/magic/Magdir/elf
+@@ -91,5 +91,5 @@
+ >>18 leshort 48 Hitachi H8S,
+ >>18 leshort 49 Hitachi H8/500,
+->>18 leshort 50 IA-64 (Intel 64 bit architecture)
++>>18 leshort 50 IA-64,
+ >>18 leshort 51 Stanford MIPS-X,
+ >>18 leshort 52 Motorola Coldfire,
+@@ -178,5 +178,5 @@
+ >>18 beshort 48 Hitachi H8S,
+ >>18 beshort 49 Hitachi H8/500,
+->>18 beshort 50 Intel Merced Processor,
++>>18 beshort 50 IA-64,
+ >>18 beshort 51 Stanford MIPS-X,
+ >>18 beshort 52 Motorola Coldfire,