summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-27 18:34:53 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-27 18:34:53 +0000
commit3733f2e2307a440a55b8502549b07d30b21eb0db (patch)
treee1e273180284f33f8678c2640c307491a7f2d6ca /sys-apps/file
parentold (diff)
downloadgentoo-2-3733f2e2307a440a55b8502549b07d30b21eb0db.tar.gz
gentoo-2-3733f2e2307a440a55b8502549b07d30b21eb0db.tar.bz2
gentoo-2-3733f2e2307a440a55b8502549b07d30b21eb0db.zip
Version bump.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-4.22.ebuild58
-rw-r--r--sys-apps/file/files/digest-file-4.223
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 18dd81db467b..ddabde53b831 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.152 2007/07/16 18:52:56 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.153 2007/12/27 18:34:53 vapier Exp $
+
+*file-4.22 (27 Dec 2007)
+
+ 27 Dec 2007; Mike Frysinger <vapier@gentoo.org> +file-4.22.ebuild:
+ Version bump.
16 Jul 2007; Markus Rothe <corsair@gentoo.org> file-4.21-r1.ebuild:
Stable on ppc64; bug #174217
diff --git a/sys-apps/file/file-4.22.ebuild b/sys-apps/file/file-4.22.ebuild
new file mode 100644
index 000000000000..353f50fed21b
--- /dev/null
+++ b/sys-apps/file/file-4.22.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.22.ebuild,v 1.1 2007/12/27 18:34:53 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.22 b/sys-apps/file/files/digest-file-4.22
new file mode 100644
index 000000000000..e0ca352fab23
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.22
@@ -0,0 +1,3 @@
+MD5 2e44d3b5bae6eea363f52ba051012145 file-4.22.tar.gz 563603
+RMD160 809dfd6dc17d867b4a8a22c595d47e62fb7f5445 file-4.22.tar.gz 563603
+SHA256 4e925dcc759a36d04ccb400b19eda74d95c5078c2094d288683dd54f32bde769 file-4.22.tar.gz 563603